On Fri, Jun 26, 2026 at 8:36 PM Danilo Krummrich <[email protected]> wrote: > > Rename ForLt to CovariantForLt to prepare for the introduction of a new > ForLt base trait that does not require covariance. > > The existing ForLt trait requires covariance, which enables the safe > cast_ref() method. This rename preserves the same semantics under a more > precise name, making room for a weaker ForLt trait in a subsequent > commit. > > No functional change. > > Reviewed-by: Alexandre Courbot <[email protected]> > Reviewed-by: Gary Guo <[email protected]> > Signed-off-by: Danilo Krummrich <[email protected]>
I don't see anyone else in linux-next using it, so this is likely fine -- if we expect others this cycle, they may need a merge. Acked-by: Miguel Ojeda <[email protected]> Cheers, Miguel
