On Wed, 2026-07-01 at 14:20 +0200, AngeloGioacchino Del Regno wrote:
> In preparation for a major refactoring of MMSYS, MUTEX and of
> mediatek-drm, move the mtk_ddp_comp_type enumeration to the
> mtk-mmsys.h header, as this will be shared between multiple
> MediaTek multimedia related drivers.
> 
> Signed-off-by: AngeloGioacchino Del Regno 
> <[email protected]>
> ---
>  drivers/gpu/drm/mediatek/mtk_ddp_comp.h | 25 ------------------
>  include/linux/soc/mediatek/mtk-mmsys.h  | 34 +++++++++++++++++++++++++
>  2 files changed, 34 insertions(+), 25 deletions(-)
> 
> diff --git a/drivers/gpu/drm/mediatek/mtk_ddp_comp.h 
> b/drivers/gpu/drm/mediatek/mtk_ddp_comp.h
> index 99bf1e1015da..bbc66072fe6b 100644
> --- a/drivers/gpu/drm/mediatek/mtk_ddp_comp.h
> +++ b/drivers/gpu/drm/mediatek/mtk_ddp_comp.h
> @@ -22,31 +22,6 @@ struct mtk_plane_state;
>  struct drm_crtc_state;
>  struct drm_dsc_config;
>  
> -enum mtk_ddp_comp_type {
> -     MTK_DISP_AAL,
> -     MTK_DISP_BLS,
> -     MTK_DISP_CCORR,
> -     MTK_DISP_COLOR,
> -     MTK_DISP_DITHER,
> -     MTK_DISP_DSC,
> -     MTK_DISP_GAMMA,
> -     MTK_DISP_MERGE,
> -     MTK_DISP_MUTEX,
> -     MTK_DISP_OD,
> -     MTK_DISP_OVL,
> -     MTK_DISP_OVL_2L,
> -     MTK_DISP_OVL_ADAPTOR,
> -     MTK_DISP_POSTMASK,
> -     MTK_DISP_PWM,
> -     MTK_DISP_RDMA,
> -     MTK_DISP_UFOE,
> -     MTK_DISP_WDMA,
> -     MTK_DPI,
> -     MTK_DP_INTF,
> -     MTK_DSI,
> -     MTK_DDP_COMP_TYPE_MAX,
> -};
> -
>  struct mtk_ddp_comp;
>  struct cmdq_pkt;
>  struct mtk_ddp_comp_funcs {
> diff --git a/include/linux/soc/mediatek/mtk-mmsys.h 
> b/include/linux/soc/mediatek/mtk-mmsys.h
> index 4885b065b849..3ddfdeac658d 100644
> --- a/include/linux/soc/mediatek/mtk-mmsys.h
> +++ b/include/linux/soc/mediatek/mtk-mmsys.h
> @@ -84,6 +84,40 @@ enum mtk_ddp_comp_id {
>       DDP_COMPONENT_ID_MAX,
>  };
>  
> +enum mtk_ddp_comp_type {
> +     /* DISP Components */
> +     MTK_DISP_AAL,
> +     MTK_DISP_BLS,
> +     MTK_DISP_CCORR,
> +     MTK_DISP_COLOR,
> +     MTK_DISP_DITHER,
> +     MTK_DISP_DSC,
> +     MTK_DISP_ETHDR_MIXER,

Let this patch just 'move'.
Separate new add to another patch.

> +     MTK_DISP_GAMMA,
> +     MTK_DISP_MERGE,
> +     MTK_DISP_MUTEX,
> +     MTK_DISP_OD,
> +     MTK_DISP_OVL,
> +     MTK_DISP_OVL_2L,
> +     MTK_DISP_OVL_ADAPTOR,
> +     MTK_DISP_PADDING,

Ditto.

> +     MTK_DISP_POSTMASK,
> +     MTK_DISP_PWM,
> +     MTK_DISP_RDMA,
> +     MTK_DISP_UFOE,
> +     MTK_DISP_WDMA,
> +
> +     /* MDP Components */
> +     MTK_DISP_MDP_RDMA,

Ditto.

Regards,
CK

> +
> +     /* Keep Display outputs at the end for readability */
> +     MTK_DPI,
> +     MTK_DP_INTF,
> +     MTK_DSI,
> +
> +     MTK_DDP_COMP_TYPE_MAX
> +};
> +
>  void mtk_mmsys_ddp_connect(struct device *dev,
>                          enum mtk_ddp_comp_id cur,
>                          enum mtk_ddp_comp_id next);

Reply via email to