Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider: - [Low] Incomplete rename of the `state` field to `state_to_destroy` in `struct __drm_colorops_state` causes a compilation failure. --
--- Patch [1]: [PATCH RFC 1/8] drm/atomic: colorop: Rename state to state_to_destroy --- commit d09bd0c6257ce0056d0f8ea064c0723f0d09039a Author: Maxime Ripard <[email protected]> drm/atomic: colorop: Rename state to state_to_destroy This patch renames the state field to state_to_destroy in the __drm_colorops_state structure to better describe its purpose and match other atomic state tracking structures. > diff --git a/include/drm/drm_atomic.h b/include/drm/drm_atomic.h > --- a/include/drm/drm_atomic.h > +++ b/include/drm/drm_atomic.h > @@ -159,7 +159,23 @@ struct drm_crtc_commit { > > struct __drm_colorops_state { > struct drm_colorop *ptr; > - struct drm_colorop_state *state, *old_state, *new_state; > + > + /** > + * @state_to_destroy: [ ... ] > + struct drm_colorop_state *state_to_destroy; > + > + struct drm_colorop_state *old_state, *new_state; > }; [Severity: Low] Does this incomplete rename cause a compilation failure? In drivers/gpu/drm/drm_atomic.c:drm_atomic_get_colorop_state(), the code still attempts to assign to the old field name: state->colorops[index].state = colorop_state; state->colorops[index].ptr = colorop; state->colorops[index].old_state = colorop->state; Should this be updated to state_to_destroy as well? -- Sashiko AI review ยท https://sashiko.dev/#/patchset/[email protected]?part=1
