On Sat, May 30, 2026 at 01:13:42PM -0700, Rosen Penev wrote:
> The kernel-doc referred to @crtc_clk_rate but the actual parameter is
> @mode_clk_rate.
>
> Assisted-by: Opencode:Big-pickle
> Signed-off-by: Rosen Penev <[email protected]>
> ---
> drivers/gpu/drm/msm/disp/dpu1/dpu_core_perf.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
Fixes: 62b7d6835288 ("drm/msm/dpu: Filter modes based on adjusted mode clock")
Reviewed-by: Dmitry Baryshkov <[email protected]>
>
> diff --git a/drivers/gpu/drm/msm/disp/dpu1/dpu_core_perf.c
> b/drivers/gpu/drm/msm/disp/dpu1/dpu_core_perf.c
> index 13cc658065c5..2ff255d7795e 100644
> --- a/drivers/gpu/drm/msm/disp/dpu1/dpu_core_perf.c
> +++ b/drivers/gpu/drm/msm/disp/dpu1/dpu_core_perf.c
> @@ -34,7 +34,7 @@ enum dpu_perf_mode {
> /**
> * dpu_core_perf_adjusted_mode_clk - Adjust given mode clock rate according
> to
> * the perf clock factor.
> - * @crtc_clk_rate - Unadjusted mode clock rate
> + * @mode_clk_rate: unadjusted mode clock rate
> * @perf_cfg: performance configuration
> */
> u64 dpu_core_perf_adjusted_mode_clk(u64 mode_clk_rate,
> --
> 2.54.0
>
--
With best wishes
Dmitry