Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider: - [Low] Non-standard generic node name used in the device tree example. The Devicetree specification recommends using standard generic names for device nodes to represent the class of the device rather than the specific model or bus type (e.g., `bridge@` instead of `mipi-bridge@`). --
--- Patch [1]: [PATCH v15 1/2] dt-bindings: bridge: Add Lontium LT7911EXC eDP to MIPI DSI bridge --- commit 5c0643686f137815285d63f46eecfcaaaad55330 Author: Sunyun Yang <[email protected]> dt-bindings: bridge: Add Lontium LT7911EXC eDP to MIPI DSI bridge This commit adds the device tree binding schema for the Lontium LT7911EXC. It documents an I2C-controlled bridge that converts eDP 1.4 input to MIPI DSI output. > diff --git > a/Documentation/devicetree/bindings/display/bridge/lontium,lt7911exc.yaml > b/Documentation/devicetree/bindings/display/bridge/lontium,lt7911exc.yaml > new file mode 100644 > index 0000000000000..3290b10ce8835 > --- /dev/null > +++ b/Documentation/devicetree/bindings/display/bridge/lontium,lt7911exc.yaml [ ... ] > +examples: > + - | > + #include <dt-bindings/gpio/gpio.h> > + i2c { > + #address-cells = <1>; > + #size-cells = <0>; > + > + mipi-bridge@41 { [Severity: Low] This isn't a bug, but should this node name use a standard generic name like bridge@41 instead of mipi-bridge@41? The Devicetree specification recommends using standard generic names to represent the class of the device rather than the specific bus type, which helps avoid dt-schema warnings. > + compatible = "lontium,lt7911exc"; > + reg = <0x41>; > + reset-gpios = <&gpy8 8 GPIO_ACTIVE_LOW>; [ ... ] -- Sashiko AI review ยท https://sashiko.dev/#/patchset/[email protected]?part=1
