On Fri, Aug 14, 2026 at 4:07 PM Luca Ceresoli <[email protected]> wrote:

> Now a panel_bridge is automatically created for every drm_panel, so this
> code (similar to an open-coded variant of drm_of_find_panel_or_bridge())
> would lead to creating a second panel_bridge for the same panel.
>
> Fix and simplify the code by just getting a reference to the
> already-existing bridge.
>
> Also keep the "connected to non-panel bridge (unsupported)\n" error logic
> by using the drm_bridge_is_panel() function.
>
> Signed-off-by: Luca Ceresoli <[email protected]>

Looks good to me!
Reviewed-by: Linus Walleij <[email protected]>

Yours,
Linus Walleij

Reply via email to