On 2026-08-25 00:28, Leon Romanovsky wrote: > From: Leon Romanovsky <[email protected]> > > Commit 95308225e5ba ("dma-buf: Rename dma_buf_move_notify() to > dma_buf_invalidate_mappings()") left the DMABUF section of the P2PDMA > documentation pointing at move_notify(), a symbol that no longer > exists. Readers grepping for it find nothing, and this is the only > place in Documentation/ describing the revocation requirement. > > Name the current function and record that importers which cannot unmap > within bounded time have to be rejected at attach time, which is what > makes the synchronous unmap on remove() achievable. > > Fixes: 95308225e5ba ("dma-buf: Rename dma_buf_move_notify() to > dma_buf_invalidate_mappings()") > Signed-off-by: Leon Romanovsky <[email protected]> Reviewed-by: Logan Gunthorpe <[email protected]>
- Re: [PATCH 2/2] dma-buf: Document how expor... Christian König
- Re: [PATCH 2/2] dma-buf: Document how e... Leon Romanovsky
- Re: [PATCH 2/2] dma-buf: Document ... Christian König
- Re: [PATCH 2/2] dma-buf: Docum... Jason Gunthorpe
- Re: [Linaro-mm-sig] [PATCH 2/2] dma-buf: Document h... Thomas Hellström
- Re: [Linaro-mm-sig] [PATCH 2/2] dma-buf: Docume... Leon Romanovsky
- Re: [Linaro-mm-sig] [PATCH 2/2] dma-buf: Do... Thomas Hellström
- Re: [Linaro-mm-sig] [PATCH 2/2] dma-buf: Do... Christian König
- [PATCH 1/2] PCI/P2PDMA: Update DMABUF lifecycle docs aft... Leon Romanovsky
- Re: [PATCH 1/2] PCI/P2PDMA: Update DMABUF lifecycle... sashiko-bot
- Re: [PATCH 1/2] PCI/P2PDMA: Update DMABUF lifecycle... Logan Gunthorpe
- Re: [PATCH 1/2] PCI/P2PDMA: Update DMABUF lifecycle... Christian König
- Re: [PATCH 1/2] PCI/P2PDMA: Update DMABUF lifecycle... Bjorn Helgaas
- Re: [PATCH 1/2] PCI/P2PDMA: Update DMABUF lifec... Leon Romanovsky
