> Add display_panic_screen to struct drm_plane_funcs. If set on a plane, > register a panic handler for the plane from the DRM core's panic > handling. Invoke this helper from the core to display a panic screen. > > The new callback replaces get_scanout_buffer as signal for panic > support in a plane. Using get_scanout_buffer is now merely a detail > of the implementation. This will also free struct drm_scanout_buffer > for use cases besides panic handling. > > With display_panic_screen in place, rename draw_panic_plane() to > drm_plane_helper_display_panic_screen() and make it available to DRM > drivers via drm_panic_helper.h. Do not change the implementation or > functionality of this code. drm_plane_helper_display_panic_screen() > still supports kernel messages, user messages and QR codes on various > color formats. > [ ... ] > - only consider planes with get_scanout_buffer (Sashiko) > - set callback for planes create with drm_crtc_init() (Sashiko) > - return errno code from display_panic_screen > > Signed-off-by: Thomas Zimmermann <[email protected]>
Sashiko has reviewed this patch and found no issues. It looks great! -- Sashiko AI review ยท https://sashiko.dev/#/patchset/[email protected]?part=11
