> > I'd like the method to look at bit less > > ad-hoc and more confined. So would you: > > > > - Move it to `falcon/gsp.rs` and implement it only to `Falcon<Gsp>`, as > > that's the only case where we need it so far, > > - Make `ctx_dma` a `usize` (it's the caller's problem to provide the > > correct type), > > - Add the `FalconFbifTarget` and `FalconFbifMemType` as arguments of the > > method, > > - Maybe rename it to `set_fbif_transcfg`, because the fact we touch > > registers is an abstraction detail. > > > > As a side-note, the series is going to clash heavily with Gary's, and > > will need to be rebased on top of it after Gary's series is merged > > (which as far as I'm concerned should be the next version). >
> Thanks for the review I'll refacto on a v2 like that then and wait for > Gary's series to rebase and send it. I see the patch have been merged [1], so I'll rebase and make a refacto for a v2 [1] https://gitlab.freedesktop.org/drm/rust/kernel/-/commit/ea79a50124315589da68cbcaf518455a142d6d23
signature.asc
Description: OpenPGP digital signature
