BarUser should not use 'gpu as a name for its lifetime; stick to a generic 'a until we need pin-init selfref for this struct.
Signed-off-by: Danilo Krummrich <[email protected]> --- drivers/gpu/nova-core/mm/bar_user.rs | 10 +++++----- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/drivers/gpu/nova-core/mm/bar_user.rs b/drivers/gpu/nova-core/mm/bar_user.rs index 855244f06983..dbf6445fa9ce 100644 --- a/drivers/gpu/nova-core/mm/bar_user.rs +++ b/drivers/gpu/nova-core/mm/bar_user.rs @@ -35,20 +35,20 @@ /// /// Owns the [`Vmm`] for the BAR1 address space. #[pin_data] -pub(crate) struct BarUser<'gpu> { +pub(crate) struct BarUser<'a> { #[pin] vmm: Mutex<Vmm>, - bar1: Bar1<'gpu>, + bar1: Bar1<'a>, } -impl<'gpu> BarUser<'gpu> { +impl<'a> BarUser<'a> { /// Create a pin-initializer for [`BarUser`]. pub(crate) fn new( pdb_addr: VramAddress, chipset: Chipset, va_size: u64, - bar1: Bar1<'gpu>, - ) -> impl PinInit<Self, Error> + 'gpu { + bar1: Bar1<'a>, + ) -> impl PinInit<Self, Error> + 'a { try_pin_init!(Self { vmm <- new_mutex!( Vmm::new(pdb_addr, chipset.mmu_version(), va_size)?, -- 2.55.0
