On Tue, Sep 22, 2026 at 09:45:04PM +0100, Karunika Choo wrote: > Mali 5th-Gen AM GPUs expose an AM_SYSTEM block for GPU-wide control > outside the main GPU register window.
A nit, subject: drop second/last, redundant "bindings". The "dt-bindings" prefix is already stating that these are bindings. See also: https://elixir.bootlin.com/linux/v7.1-rc7/source/Documentation/devicetree/bindings/submitting-patches.rst#L23 > > Document the system node compatible, register and interrupt resources, > GPU clock, and optional GPU regulator supply used by the AM_SYSTEM > platform driver. > > Signed-off-by: Karunika Choo <[email protected]> > --- > .../bindings/gpu/arm,mali-gen5-am-system.yaml | 67 +++++++++++++++++++ > MAINTAINERS | 1 + > 2 files changed, 68 insertions(+) > create mode 100644 > Documentation/devicetree/bindings/gpu/arm,mali-gen5-am-system.yaml > > diff --git > a/Documentation/devicetree/bindings/gpu/arm,mali-gen5-am-system.yaml > b/Documentation/devicetree/bindings/gpu/arm,mali-gen5-am-system.yaml > new file mode 100644 > index 0000000000000..f0689bb8f05a2 > --- /dev/null > +++ b/Documentation/devicetree/bindings/gpu/arm,mali-gen5-am-system.yaml > @@ -0,0 +1,67 @@ > +# SPDX-License-Identifier: GPL-2.0-only OR BSD-2-Clause > +# Copyright 2026 ARM Limited. All rights reserved. > +%YAML 1.2 > +--- > +$id: http://devicetree.org/schemas/gpu/arm,mali-gen5-am-system.yaml# > +$schema: http://devicetree.org/meta-schemas/core.yaml# > + > +title: ARM Mali 5th-Gen GPU System Device > + > +maintainers: > + - Liviu Dudau <[email protected]> > + - Boris Brezillon <[email protected]> > + > +properties: > + $nodename: > + pattern: '^panthor-system@[a-f0-9]+$' Nope. Why would we name devices based on driver? Node names should be generic. See also an explanation and list of examples (not exhaustive) in DT specification: https://devicetree-specification.readthedocs.io/en/latest/chapter2-devicetree-basics.html#generic-names-recommendation If you cannot find a name matching your device, please check in kernel sources for similar cases or you can grow the spec (via pull request to DT spec repo). Drop the nodename completely. > + > + compatible: > + oneOf: Drop > + - items: Probably drop... but: > + - const: arm,mali-gen5-am-system How can this be used alone? > + > + reg: > + items: > + - description: System register so just maxItems: 1 > + > + reg-names: > + items: > + - const: system Drop entire reg-names > + > + interrupts: > + items: > + - description: System interrupt keep it simple, maxItems: 1 > + > + clocks: > + maxItems: 1 > + description: > + Phandle to the GPU clock. Drop description, obvious. Can this be something else than phandle? Can a single clock for GPU can be something else than GPU clock? > + > + gpu-supply: true This should rather be named based on the pins/domains. Are you sure the domain is called GPU? > + > + dma-coherent: true > + > +required: > + - compatible > + - reg > + - reg-names > + - interrupts > + - clocks > + > +additionalProperties: false > + > +examples: > + - | > + #include <dt-bindings/interrupt-controller/irq.h> > + #include <dt-bindings/interrupt-controller/arm-gic.h> > + > + panthor_system: panthor-system@68000000 { Drop unused label Best regards, Krzysztof
