Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider: - [Low] dt: node names use underscores instead of hyphens --
commit 13a81e24cfdf82fcd1a6606b31ae481417af3552 Author: Maxime Ripard <[email protected]> arm64: dts: broadcom: Add Raspberry Pi ILI9881C DSI panel overlays This commit adds device tree overlays for the Raspberry Pi 5-inch and 7-inch MIPI-DSI panels on the Raspberry Pi 4 Model B. It introduces a shared dtsi for the common display MCU and backlight components. > diff --git a/arch/arm64/boot/dts/broadcom/bcm2711-rpi-4-b-dsi-ili9881.dtsi > b/arch/arm64/boot/dts/broadcom/bcm2711-rpi-4-b-dsi-ili9881.dtsi > new file mode 100644 > index 0000000000000..bd08e22581a31 > --- /dev/null > +++ b/arch/arm64/boot/dts/broadcom/bcm2711-rpi-4-b-dsi-ili9881.dtsi [ ... ] > +&{/} { > + panel_backlight: panel_backlight { [Severity: Low] Should this node name use hyphens instead of underscores, such as panel-backlight? Devicetree naming conventions generally prefer hyphens, and using underscores here triggers node_name_chars_strict warnings when building the device trees with standard strict dtc checks enabled. > + compatible = "pwm-backlight"; > + brightness-levels = <0 31>; [ ... ] > +&i2c0_1 { > + status = "okay"; > + > + display_mcu: display_mcu@45 { [Severity: Low] Similarly, could this node be named display-mcu@45 instead? Replacing the underscore with a hyphen avoids dtc compiler warnings for invalid node name characters. > + compatible = "raspberrypi,touchscreen-panel-regulator-v2"; > + reg = <0x45>; > + gpio-controller; -- Sashiko AI review ยท https://sashiko.dev/#/patchset/[email protected]?part=6
