On Tue, Sep 29, 2026 at 09:03:17AM +0100, Jason Gunthorpe wrote: > On Tue, Sep 29, 2026 at 08:56:01AM +0200, Karl Mehltretter wrote: > > Right, the misc device has no dma_parms, so it gets the 64K default and > > sync fails with 256K pages > > I would ignore this, it seems fictional to me, and if someone really > needs to support this rediculous combination it should be done inside > sg_alloc_table_from_pages_segment(:) >
Fair enough, Sashiko got me there. Looking around, 256K pages seem to be barely supported today: they were already disabled for 47x, and I couldn't get userspace running on a 256K-page 44x kernel in QEMU. I'll leave v2 as is. Thanks for the review. Karl
