Thank you for your contribution! Sashiko AI review found 1 potential issue(s) 
to consider:
- [Low] drm: outdated helper function names in drm_atomic documentation
--

commit 1f801641406daea3f9369bcd8c55bd29b23f3328
Author: Luca Ceresoli <[email protected]>

drm/atomic: move drm_atomic_helper_disable_all() and 
drm_atomic_helper_shutdown() from drm_atomic_helper to drm_atomic

This patch moves drm_atomic_helper_shutdown() and its callee
drm_atomic_helper_disable_all() from the drm_kms_helper module to the drm
module, renaming them to drm_atomic_shutdown() and drm_atomic_disable_all().
The original functions are kept as deprecated wrappers to avoid a module
dependency loop.

> diff --git a/drivers/gpu/drm/drm_atomic.c b/drivers/gpu/drm/drm_atomic.c
> index 9bb761eda59f4..ec7a0f369c8b0 100644
> --- a/drivers/gpu/drm/drm_atomic.c
> +++ b/drivers/gpu/drm/drm_atomic.c
> @@ -2081,6 +2081,121 @@ int __drm_atomic_helper_set_config(struct 
> drm_mode_set *set,

[ ... ]

> + * Note that if callers haven't already acquired all modeset locks this might
> + * return -EDEADLK, which must be handled by calling drm_modeset_backoff().
> + *
> + * Returns:
> + * 0 on success or a negative error code on failure.
> + *
> + * See also:
> + * drm_atomic_helper_suspend(), drm_atomic_helper_resume() and
> + * drm_atomic_helper_shutdown().
> + */
> +int drm_atomic_disable_all(struct drm_device *dev,
> +                        struct drm_modeset_acquire_ctx *ctx)

[Severity: Low]
Should this "See also" section refer to the newly renamed
drm_atomic_shutdown() instead of the deprecated
drm_atomic_helper_shutdown() wrapper?

[ ... ]

> +/**
> + * drm_atomic_shutdown - shutdown all CRTC
> + * @dev: DRM device
> + *
> + * This shuts down all CRTC, which is useful for driver unloading. Shutdown 
> on
> + * suspend should instead be handled with drm_atomic_helper_suspend(), since
> + * that also takes a snapshot of the modeset state to be restored on resume.
> + *
> + * This is just a convenience wrapper around drm_atomic_helper_disable_all(),
> + * and it is the atomic version of drm_helper_force_disable_all().
> + */
> +void drm_atomic_shutdown(struct drm_device *dev)

[Severity: Low]
Does this documentation need to be updated to mention it wraps
drm_atomic_disable_all() instead of the deprecated
drm_atomic_helper_disable_all() function?

-- 
Sashiko AI review ยท 
https://sashiko.dev/#/patchset/[email protected]?part=11

Reply via email to