On Tue, 2026-07-14 at 13:43 +0200, AngeloGioacchino Del Regno wrote: > Since mediatek-drm shifted from hardcoded per-SoC-per-Board path > definitions for the display controller to devicetree graph based > path building, the first ones are used less and less, and those > are also decreasing ease of code browsability (hence, readability) > in the mtk_drm_drv.c file. > > This means that those big arrays are almost irrelevant now (for > modern code, of course). > > Seen the need to keep compatibility with older devicetrees, then, > move all of the deprecated arrays in new mtk_drm_legacy files and > add a big warning to those, explaining that no new SoCs must be > implemented like so, and making it clear that it shall exclusively > contain legacy and deprecated code. > > Also, especially with the restructuring work that is currently in > progress (with MuteX finally getting trigger-sources support and > other changes that will follow), it is expected to see more code > being moved in the mtk_drm_legacy territory.
Reviewed-by: CK Hu <[email protected]> > > Signed-off-by: AngeloGioacchino Del Regno > <[email protected]> > ---
