> The connector type passed to devm_drm_panel_bridge_add_typed() has been
> ignored since commit b7797081ccfe ("drm/panel: embed a drm_bridge into
> every drm_panel"), the bridge always has the type of the panel.
>
> Assisted-by: LLM
> Signed-off-by: Dmitry Baryshkov <[email protected]>
>
> diff --git a/drivers/gpu/drm/bridge/lvds-codec.c
> b/drivers/gpu/drm/bridge/lvds-codec.c
> index f97c8586273d..d25d8d777191 100644
> --- a/drivers/gpu/drm/bridge/lvds-codec.c
> +++ b/drivers/gpu/drm/bridge/lvds-codec.c
> @@ -154,8 +154,7 @@ static int lvds_codec_probe(struct platform_device *pdev)
> }
>
> lvds_codec->panel_bridge =
> - devm_drm_panel_bridge_add_typed(dev, panel,
> - lvds_codec->connector_type);
> + devm_drm_panel_bridge_add(dev, panel);
> drm_panel_put(panel);
> if (IS_ERR(lvds_codec->panel_bridge))
> return PTR_ERR(lvds_codec->panel_bridge);
By now drm_of_find_panel_or_bridge() + devm_drm_panel_bridge_add_typed() is
jsut a complicated wrapper to drm_bridge_get(), so this driver and those in
the following commits could be simplified dramatically, without adding the
deprecated devm_drm_panel_bridge_add().
However devm_drm_panel_bridge_add_typed() is _more_ deprecated than
devm_drm_panel_bridge_add(), so this is already a good step forward.
Reviewed-by: Luca Ceresoli <[email protected]>
Luca
--
Luca Ceresoli, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com