Keith Packard wrote:
> commit 32acf53eefa64cd41cc9bf45705b0825fc8a0eef
> Author: Keith Packard <[EMAIL PROTECTED]>
> Date:   Sun Dec 16 20:16:50 2007 -0800
> 
>     Rename inappropriately named 'mask' fields to 'proposed_flags' instead.
>     
>     Flags pending validation were stored in a misleadingly named field, 
> 'mask'.
>     As 'mask' is already used to indicate pieces of a flags field which are
>     changing, it seems better to use a name reflecting the actual purpose of
>     this field. I chose 'proposed_flags' as they may not actually end up in
>     'flags', and in an case will be modified when they are moved over.
>     
>     This affects the API, but not ABI of the user-mode interface.
> 

Keith, I think this makes sense too.  I'm hopeful Thomas would agree.

> +/*
> + * drm_bo_propose_flags:
> + *
> + * @bo: the buffer object getting new flags
> + *
> + * @new_flags: the new set of proposed flag bits
> + *
> + * @new_mask: the mask of bits changed in new_flags
> + *
> + * Modify the proposed_flag bits in @bo
> + */

Looks like this comment has already started to drift from the function 
it is documenting??

> +static int drm_bo_modify_proposed_flags (struct drm_buffer_object *bo,
> +                                      uint64_t new_flags, uint64_t new_mask)


Keith

-------------------------------------------------------------------------
SF.Net email is sponsored by:
Check out the new SourceForge.net Marketplace.
It's the best place to buy or sell services
for just about anything Open Source.
http://ad.doubleclick.net/clk;164216239;13503038;w?http://sf.net/marketplace
--
_______________________________________________
Dri-devel mailing list
Dri-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/dri-devel

Reply via email to