A few redundant switch cases as well as a redundant if/else
within one of the cases was consolidated to a single call.
The cases are intentionally retained for documentation purposes.

Signed-off-by: Nicholas Mc Guire <hof...@osadl.org>
---
case WIFI_REASSOCREQ,WIFI_PROBEREQ,WIFI_BEACON,WIFI_ACTION all
have the same effect - notably the also for WIFI_PROBEREQ where
the if/else is executing the same function. 

These redundant cases could all be dropped and consolidated into
the default but probably it is better for documentation/readability
to leave them in the switch/case explicitly.

Patch was only compile-tested for x86_64_defconfig + CONFIG_STAGING=y
CONFIG_R8188EU=m

Patch is against 3.19.0-rc7 (localversion-next is -next-20150204)

 drivers/staging/rtl8188eu/core/rtw_mlme_ext.c |    9 ---------
 1 file changed, 9 deletions(-)

diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c 
b/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
index 28918201..cd12dd7 100644
--- a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
+++ b/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
@@ -484,17 +484,8 @@ void mgt_dispatcher(struct adapter *padapter, struct 
recv_frame *precv_frame)
                /* fall through */
        case WIFI_ASSOCREQ:
        case WIFI_REASSOCREQ:
-               _mgt_dispatcher(padapter, ptable, precv_frame);
-               break;
        case WIFI_PROBEREQ:
-               if (check_fwstate(pmlmepriv, WIFI_AP_STATE))
-                       _mgt_dispatcher(padapter, ptable, precv_frame);
-               else
-                       _mgt_dispatcher(padapter, ptable, precv_frame);
-               break;
        case WIFI_BEACON:
-               _mgt_dispatcher(padapter, ptable, precv_frame);
-               break;
        case WIFI_ACTION:
                _mgt_dispatcher(padapter, ptable, precv_frame);
                break;
-- 
1.7.10.4

_______________________________________________
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Reply via email to