On Sun, Mar 15, 2015 at 10:03:56AM +0100, Isaac Lleida wrote:
> This path implements a bit array representing the LCD signal states instead 
> of the old "struct bits", which used char to represent a single bit. This 
> will reduce the memory usage.

Sudip told you to line wrap the changelog but it's still not wrapped.

Anyway, please step back and rethink the whole approach.  It doesn't
save any memory when you consider how variables are stored in memory
(alignment) and it doesn't make the code more readable.

Both "bits.e" and "BIT_CHK(bits, LCD_BIT_E_MASK)" are terrible.  The new
one is worse because it takes more words to tell you nothing and because
it is wrong since E is a flag not a mask.

Think about how you can make it more clear.

regards,
dan carpenter

_______________________________________________
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Reply via email to