On 07/08/15 19:45, H Hartley Sweeten wrote:
The hwdrv_apci1564.c file is included by the addi_apci_1564 driver to provide
the support code for the timer and counter subdevices. The code in this file
is broken with respect to how comedi works with subdevices.
Tidy it up so that it can be fixed.
H Hartley Sweeten (14):
staging: comedi: addi_tcw.h: prefer using the BIT macro
staging: comedi: hwdrv_apci1564: remove unused defines
staging: comedi: addi_apci_1564: define the APCI1564_DO_INT_CTRL_REG bits
staging: comedi: addi_apci_1564: define the APCI1564_DO_INT_STATUS_REG bits
staging: comedi: addi_apci_1564: define the APCI1564_DO_IRQ_REG bits
staging: comedi: addi_apci_1564: define the APCI1564_DI_IRQ_REG bits
staging: comedi: addi_apci_1564: tidy up APCI1564_EEPROM_REG bit defines
staging: comedi: hwdrv_apci1564: use addi_tcw.h defines
staging: comedi: hwdrv_apci1564: tidy up apci1564_timer_insn_write()
staging: comedi: hwdrv_apci1564: remove magic number in
apci1564_timer_insn_read()
staging: comedi: hwdrv_apci1564: remove useless code in
apci1564_counter_insn_config()
staging: comedi: hwdrv_apci1564: fix counter "mode" setting
staging: comedi: hwdrv_apci1564: tidy up apci1564_counter_insn_write()
staging: comedi: hwdrv_apci1564: remove magic numbers in
apci1564_counter_insn_read()
.../comedi/drivers/addi-data/hwdrv_apci1564.c | 93 +++++++++-------------
drivers/staging/comedi/drivers/addi_apci_1564.c | 35 ++++----
drivers/staging/comedi/drivers/addi_tcw.h | 63 ++++++++-------
3 files changed, 93 insertions(+), 98 deletions(-)
Looks good.
Reviewed-by: Ian Abbott <abbo...@mev.co.uk>
--
-=( Ian Abbott @ MEV Ltd. E-mail: <abbo...@mev.co.uk> )=-
-=( Web: http://www.mev.co.uk/ )=-
_______________________________________________
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel