On Thu, Oct 29, 2015 at 12:18:51PM +0900, Glen Lee wrote:
> This patch rename os_context to wilc because it is used as struct wilc and
> move os_private from struct wilc_wlan_os_context_t to struct wilc_wlan_inp_t.
> Finally, delete wilc_wlan_os_context_t.
> 
> Signed-off-by: Glen Lee <glen....@atmel.com>
> ---
>  drivers/staging/wilc1000/linux_wlan.c   | 2 +-
>  drivers/staging/wilc1000/wilc_sdio.c    | 6 +++---
>  drivers/staging/wilc1000/wilc_spi.c     | 6 +++---
>  drivers/staging/wilc1000/wilc_wlan_if.h | 6 +-----
>  4 files changed, 8 insertions(+), 12 deletions(-)
> 
> diff --git a/drivers/staging/wilc1000/linux_wlan.c 
> b/drivers/staging/wilc1000/linux_wlan.c
> index 017799f..d0161cd 100644
> --- a/drivers/staging/wilc1000/linux_wlan.c
> +++ b/drivers/staging/wilc1000/linux_wlan.c
> @@ -1012,7 +1012,7 @@ void linux_to_wlan(wilc_wlan_inp_t *nwi, struct wilc 
> *nic)
>  
>       PRINT_D(INIT_DBG, "Linux to Wlan services ...\n");
>  
> -     nwi->os_context.os_private = (void *)nic;
> +     nwi->wilc = (void *)nic;

Why do you need the cast to a void * here?


>  
>  #ifdef WILC_SDIO
>       nwi->io_func.io_type = HIF_SDIO;
> diff --git a/drivers/staging/wilc1000/wilc_sdio.c 
> b/drivers/staging/wilc1000/wilc_sdio.c
> index 300c571..82f68eb 100644
> --- a/drivers/staging/wilc1000/wilc_sdio.c
> +++ b/drivers/staging/wilc1000/wilc_sdio.c
> @@ -14,7 +14,7 @@
>  #define WILC_SDIO_BLOCK_SIZE 512
>  
>  typedef struct {
> -     void *os_context;
> +     void *wilc;

This should be a struct wilc *, right?  Don't add a void pointer for
something that you know what it is.

thanks,

greg k-h
_______________________________________________
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Reply via email to