On 18/11/15 17:07, H Hartley Sweeten wrote:
These defines are only used to initialize the diosubd_data 'addr' members
in the boardinfo. For aesthetics, just open-code the values and remove the
defines.

Signed-off-by: H Hartley Sweeten <hswee...@visionengravers.com>
Cc: Ian Abbott <abbo...@mev.co.uk>
Cc: Greg Kroah-Hartman <gre...@linuxfoundation.org>
---
  drivers/staging/comedi/drivers/adv_pci_dio.c | 32 +++++++++-------------------
  1 file changed, 10 insertions(+), 22 deletions(-)

diff --git a/drivers/staging/comedi/drivers/adv_pci_dio.c 
b/drivers/staging/comedi/drivers/adv_pci_dio.c
index 578c646..a72b04e 100644
--- a/drivers/staging/comedi/drivers/adv_pci_dio.c
+++ b/drivers/staging/comedi/drivers/adv_pci_dio.c
[snip]

@@ -233,7 +221,7 @@ static const struct dio_boardtype boardtypes[] = {
                .cardtype       = TYPE_PCI1762,
                .nsubdevs       = 3,
                .sdi[1]         = { 16, 0x02, },        /* ISO DI 0-15 */
-               .sdo[1]         = { 16, PCI1762_RO, },
+               .sdo[1]         = { 16, 0x00, },        /* ISO DO 0-15 */

The comment is slightly wrong.  Those are relay outputs.

--
-=( Ian Abbott @ MEV Ltd.    E-mail: <abbo...@mev.co.uk> )=-
-=(                          Web: http://www.mev.co.uk/  )=-
_______________________________________________
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Reply via email to