On Wed, Feb 10, 2016 at 06:33:55PM +0200, Mike Rapoport wrote:
> Several PLL control registers have the same layout and therefore the
> field definitions may be shared for those registers. Renaming
> definitions of PANEL_PLL_CTRL_* fields to more generic PLL_CTRL_* will
> allow reusing these definitions for other PLL control registers.
> 
> Signed-off-by: Mike Rapoport <mike.rapop...@gmail.com>
> ---
<snip>
> diff --git a/drivers/staging/sm750fb/ddk750_display.c 
> b/drivers/staging/sm750fb/ddk750_display.c
> index 1a29ae0..514f909 100644
> --- a/drivers/staging/sm750fb/ddk750_display.c
> +++ b/drivers/staging/sm750fb/ddk750_display.c
> @@ -126,8 +126,8 @@ static void waitNextVerticalSync(int ctrl, int delay)
>  
>               /* Do not wait when the Primary PLL is off or display control 
> is already off.
>                  This will prevent the software to wait forever. */
> -             if ((FIELD_GET(PEEK32(PANEL_PLL_CTRL), PANEL_PLL_CTRL, POWER) ==
> -                      PANEL_PLL_CTRL_POWER_OFF) ||
> +             if ((FIELD_GET(PEEK32(PANEL_PLL_CTRL), PLL_CTRL, POWER) ==
> +                      PLL_CTRL_POWER_OFF) ||

Here you are changing one use of PANEL_PLL_CTRL to PLL_CTRL while
keeping another use unchanged. Any reason for that?

regards
sudip
_______________________________________________
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Reply via email to