On Tue, Mar 14, 2017 at 02:36:26PM +0530, Arushi Singhal wrote:
> New variables are added to make the code more readable.
> 
> Signed-off-by: Arushi Singhal <arushisinghal19971...@gmail.com>
> ---
>  changes in v3
>  - improve the patch to make code much more readable.
> 
>  drivers/staging/sm750fb/ddk750_mode.c | 115 
> ++++++++++++++++++----------------
>  1 file changed, 61 insertions(+), 54 deletions(-)
> 
> diff --git a/drivers/staging/sm750fb/ddk750_mode.c 
> b/drivers/staging/sm750fb/ddk750_mode.c
> index 25da678179f7..150e5ed0d8ea 100644
> --- a/drivers/staging/sm750fb/ddk750_mode.c
> +++ b/drivers/staging/sm750fb/ddk750_mode.c
> @@ -81,33 +81,34 @@ static int programModeRegisters(struct _mode_parameter_t 
> *pModeParam, struct pll
>       if (pll->clockType == SECONDARY_PLL) {
>               /* programe secondary pixel clock */
>               poke32(CRT_PLL_CTRL, sm750_format_pll_reg(pll));
> -             poke32(CRT_HORIZONTAL_TOTAL,
> -                    (((pModeParam->horizontal_total - 1) <<
> -                      CRT_HORIZONTAL_TOTAL_TOTAL_SHIFT) &
> -                     CRT_HORIZONTAL_TOTAL_TOTAL_MASK) |
> -                    ((pModeParam->horizontal_display_end - 1) &
> -                     CRT_HORIZONTAL_TOTAL_DISPLAY_END_MASK));
> -
> -             poke32(CRT_HORIZONTAL_SYNC,
> -                    ((pModeParam->horizontal_sync_width <<
> -                      CRT_HORIZONTAL_SYNC_WIDTH_SHIFT) &
> -                     CRT_HORIZONTAL_SYNC_WIDTH_MASK) |
> -                    ((pModeParam->horizontal_sync_start - 1) &
> -                     CRT_HORIZONTAL_SYNC_START_MASK));
> -
> -             poke32(CRT_VERTICAL_TOTAL,
> -                    (((pModeParam->vertical_total - 1) <<
> -                      CRT_VERTICAL_TOTAL_TOTAL_SHIFT) &
> -                     CRT_VERTICAL_TOTAL_TOTAL_MASK) |
> -                    ((pModeParam->vertical_display_end - 1) &
> -                     CRT_VERTICAL_TOTAL_DISPLAY_END_MASK));
> -
> -             poke32(CRT_VERTICAL_SYNC,
> -                    ((pModeParam->vertical_sync_height <<
> -                      CRT_VERTICAL_SYNC_HEIGHT_SHIFT) &
> -                     CRT_VERTICAL_SYNC_HEIGHT_MASK) |
> -                    ((pModeParam->vertical_sync_start - 1) &
> -                     CRT_VERTICAL_SYNC_START_MASK));
> +
> +             unsigned int cht = CRT_HORIZONTAL_TOTAL;
> +             unsigned int chttm = CRT_HORIZONTAL_TOTAL_TOTAL_MASK;
> +             unsigned int phde = pModeParam->horizontal_display_end - 1;
> +             unsigned int chtdem = CRT_HORIZONTAL_TOTAL_DISPLAY_END_MASK;
> +
> +             poke32(cht, (((pModeParam->horizontal_total - 1) << 
> CRT_HORIZONTAL_TOTAL_TOTAL_SHIFT) & chttm) | (phde & chtdem));
> +
> +             unsigned int chs = CRT_HORIZONTAL_SYNC;
> +             unsigned int chswm = CRT_HORIZONTAL_SYNC_WIDTH_MASK;
> +             unsigned int phss = pModeParam->horizontal_sync_start - 1;
> +             unsigned int chssm = CRT_HORIZONTAL_SYNC_START_MASK;
> +
> +             poke32(chs, ((pModeParam->horizontal_sync_width << 
> CRT_HORIZONTAL_SYNC_WIDTH_SHIFT) & chswm) | (phss & chssm));

{sigh}

Ok, please, ALWAYS do the following for your patches:
        - run checkpatch.pl and do not introduce new issues
        - test build your code and do not add new build warnings.

Don't get sloppy here, you know better than this :)

thanks,

greg k-h
_______________________________________________
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Reply via email to