Oi Gustavo,
Thanks for the patch, and the rebasing.

On Wed 17 Apr 2019 at 19:44, Gustavo A. R. Silva wrote:
Make use of the struct_size() helper instead of an open-coded version in order to avoid any potential type mistakes, in particular in the
context in which this code is being used.

So, replace code of the following form:

sizeof(*resp) + props_count * sizeof(struct gb_power_supply_props_desc)

with:

struct_size(resp, props, props_count)

This code was detected with the help of Coccinelle.

Signed-off-by: Gustavo A. R. Silva <gust...@embeddedor.com>

Reviewed-by: Rui Miguel Silva <rmf...@gmail.com>

---
Cheers,
        Rui


---
Changes in v2:
- Rebase on top of 47830c1127ef ("staging: greybus: power_supply: fix prop-descriptor request size")

 drivers/staging/greybus/power_supply.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/staging/greybus/power_supply.c b/drivers/staging/greybus/power_supply.c
index ae5c0285a942..34b40a409ea3 100644
--- a/drivers/staging/greybus/power_supply.c
+++ b/drivers/staging/greybus/power_supply.c
@@ -520,8 +520,8 @@ static int gb_power_supply_prop_descriptors_get(struct gb_power_supply *gbpsy) op = gb_operation_create(connection,
                                 GB_POWER_SUPPLY_TYPE_GET_PROP_DESCRIPTORS,
- sizeof(*req), sizeof(*resp) + props_count * - sizeof(struct gb_power_supply_props_desc),
+                                sizeof(*req),
+ struct_size(resp, props, props_count),
                                 GFP_KERNEL);
        if (!op)
                return -ENOMEM;

_______________________________________________
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Reply via email to