Replaced __attribute__((packed)) with __packed. Both ways of attributing
are equivalent, but being shorter, __packed should be preferred.
This refactoring makes the core more readable.

Signed-off-by: Fabian Krueger <fabian.krue...@fau.de>
Signed-off-by: Michael Scheiderer <michael.scheide...@fau.de>
---
 drivers/staging/kpc2000/kpc2000_spi.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/staging/kpc2000/kpc2000_spi.c 
b/drivers/staging/kpc2000/kpc2000_spi.c
index e0e7703c6e53..253a9c150d33 100644
--- a/drivers/staging/kpc2000/kpc2000_spi.c
+++ b/drivers/staging/kpc2000/kpc2000_spi.c
@@ -141,7 +141,7 @@ struct kp_spi_controller_state {
 
 union kp_spi_config {
        /* use this to access individual elements */
-       struct __attribute__((packed)) spi_config_bitfield {
+       struct __packed spi_config_bitfield {
                unsigned int pha       : 1; /* spim_clk Phase      */
                unsigned int pol       : 1; /* spim_clk Polarity   */
                unsigned int epol      : 1; /* spim_csx Polarity   */
@@ -160,7 +160,7 @@ union kp_spi_config {
 };
 
 union kp_spi_status {
-       struct __attribute__((packed)) spi_status_bitfield {
+       struct __packed spi_status_bitfield {
                unsigned int rx    :  1; /* Rx Status       */
                unsigned int tx    :  1; /* Tx Status       */
                unsigned int eo    :  1; /* End of Transfer */
@@ -175,7 +175,7 @@ union kp_spi_status {
 };
 
 union kp_spi_ffctrl {
-       struct __attribute__((packed)) spi_ffctrl_bitfield {
+       struct __packed spi_ffctrl_bitfield {
                unsigned int ffstart :  1; /* FIFO Start */
                unsigned int         : 31;
        } bitfield;
-- 
2.17.1

_______________________________________________
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Reply via email to