On Sun, 13 Oct 2019, Wambui Karuga wrote:
> Use the DIV_ROUND_UP macro to replace open-coded divisor calculation
> to improve readability.
> Issue found using coccinelle:
> @@
> expression n,d;
> @@
> (
> - ((n + d - 1) / d)
> + DIV_ROUND_UP(n,d)
> |
> - ((n + (d - 1)) / d)
> + DIV_ROUND_UP(n,d)
> )
>
> Signed-off-by: Wambui Karuga <wambui.karu...@gmail.com>
> ---
> drivers/staging/rtl8723bs/hal/rtl8723b_hal_init.c | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/drivers/staging/rtl8723bs/hal/rtl8723b_hal_init.c
> b/drivers/staging/rtl8723bs/hal/rtl8723b_hal_init.c
> index 87535a4c2e14..74312e8bb32e 100644
> --- a/drivers/staging/rtl8723bs/hal/rtl8723b_hal_init.c
> +++ b/drivers/staging/rtl8723bs/hal/rtl8723b_hal_init.c
> @@ -4158,7 +4158,8 @@ void SetHwReg8723B(struct adapter *padapter, u8
> variable, u8 *val)
>
> /* The value of ((usNavUpper +
> HAL_NAV_UPPER_UNIT_8723B - 1) / HAL_NAV_UPPER_UNIT_8723B) */
> /* is getting the upper integer. */
It's a nice change. Maybe the above comment could also be dropped, since
the code is more understandable now.
julia
> - usNavUpper = (usNavUpper + HAL_NAV_UPPER_UNIT_8723B -
> 1) / HAL_NAV_UPPER_UNIT_8723B;
> + usNavUpper = DIV_ROUND_UP(usNavUpper,
> + HAL_NAV_UPPER_UNIT_8723B);
> rtw_write8(padapter, REG_NAV_UPPER, (u8)usNavUpper);
> }
> break;
> --
> 2.23.0
>
> --
> You received this message because you are subscribed to the Google Groups
> "outreachy-kernel" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to outreachy-kernel+unsubscr...@googlegroups.com.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/outreachy-kernel/20191013180033.31882-1-wambui.karugax%40gmail.com.
>
_______________________________________________
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel