Hi!
On Aug 4, 2008, at 12:06 PM, Mats Kindahl wrote:
Maybe we should call it Session in that case? :)
Probably :)
It might seem like nitpicking, but names of entities is a guide to
what
they represent, and the THD object has more or less become a general
Agreed. I am not caring about the name at the moment mainly because I
do not believe we have a full handle on what is in it any longer. As
Jay pointed out in another piece of email on this, the documentation
on what it is at this point is quite wrong as well. When it comes to
renaming internal objects, I want to first understand what we have to
work with.
If not, "handler" would have been "cursor" some time ago :)
smaller size (especially check the number of bool fields in the
object,
each bool wastes at least 7 bits of data since at least a char has
to be
allocated for it in the structure).
If we abstract out the interfaces, internally we can do whatever we
like :)
Cheers,
-Brian
Just my few cents,
Mats Kindahl
Cheers,
-Brian
--
_______________________________________________________
Brian "Krow" Aker, brian at tangent.org
Seattle, Washington
http://krow.net/ <-- Me
http://tangent.org/ <-- Software
_______________________________________________________
You can't grep a dead tree.
--
Mats Kindahl
Lead Software Developer
Replication Team
MySQL AB, www.mysql.com
<mats.vcf>
--
_______________________________________________________
Brian "Krow" Aker, brian at tangent.org
Seattle, Washington
http://krow.net/ <-- Me
http://tangent.org/ <-- Software
_______________________________________________________
You can't grep a dead tree.
_______________________________________________
Mailing list: https://launchpad.net/~drizzle-discuss
Post to : [email protected]
Unsubscribe : https://launchpad.net/~drizzle-discuss
More help : https://help.launchpad.net/ListHelp