Hi Jay
On 05/02/2009, at 12:31 PM, Jay Pipes wrote:
On a practical note, the naming of both "auto-increment" and
"sequence" is unfortunate, because it causes implicit expectations
on the behaviour. UNIQUE_ID or GENERATOR (thank Jim!) would be
clearer, it's just intended to provide a unique ID, and nothing else.
And while in principle I can see how having it user-definable in
terms of logic can be useful, I don't think it's essential.
In SQL Server, it's called IDENTITY, which I think is a fine name.
So is generator and UNIQUE_ID. I agree with all that auto-
increments *implied* always-incrementing behaviour is not good.
IDENTITY sounds very good. Of course we'd need to look at how it
behaves for MSSQL, because if Drizzle's implementation is particularly
different, it could confuse with having the same name. Might learn
something too.
Cheers,
Arjen.
--
Arjen Lentz, Director @ Open Query (http://openquery.com.au)
MySQL Training from $475/day, DBA/Support from $249/month
My blog is at http://arjen-lentz.livejournal.com
OurDelta: free enhanced builds for MySQL @ http://ourdelta.org
_______________________________________________
Mailing list: https://launchpad.net/~drizzle-discuss
Post to : [email protected]
Unsubscribe : https://launchpad.net/~drizzle-discuss
More help : https://help.launchpad.net/ListHelp