-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
Hi all,
Monty recently brought up a good discussion/vote point on a merge
proposal from Padraig, and I think I like his idea. Just want to get
everyone's opinion on this and then we can add it to the style
guidelines online...
Basically, the rule would be:
When in a *header file*, always use an explicit namespace prefix, like so:
void myfunc(std::list some_list, drizzle::serialize::Table *some_table)
{
// blah, blah...
}
and in implementation files, use a single using namespace statement,
like so:
using namespace std;
using namespace drizzle::serialize;
void myfunc(list some_list, Table some_table)
{
// blah, blah
}
Opinions?
- -jay
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org
iEYEARECAAYFAkmzzUAACgkQ2upbWsB4UtF8mwCeJbBdsiC6Tbvi5UEcdXtFdQTM
WOMAnimzwydK01mL90Gxr8jWikaAWUYi
=hZld
-----END PGP SIGNATURE-----
_______________________________________________
Mailing list: https://launchpad.net/~drizzle-discuss
Post to : [email protected]
Unsubscribe : https://launchpad.net/~drizzle-discuss
More help : https://help.launchpad.net/ListHelp