Hi everyone, I'd be in support of camel-case filenames, or any other naming scheme for that matter to make things consistent. For example, we could go the other way and follow the C++ standard not not even using camelCase (ie, vector, priority_queue, ...). I know this has been decided and is beating a dead horse, thought I'd throw it out there.
On Fri, Aug 14, 2009 at 10:32:48AM -0700, Brian Aker wrote: > What happens when we have people editing on systems which have different > case matching rules? Windows, different mount points, etc... This should be fine, unless the filesystem is autoconverting upper to lower or vice-versa (in which case it doesn't matter what we do). There are plenty of projects out there that have camel-case names in them and work on many platforms. > Keep everything lower case. I have found that this just becomes a mess > to deal with. I made the mistake of once introducing a directory called > "Build" in MySQL where there was already one called "BUILD"... just > wasn't paying attention and I had been working Xcode. Blew up > everything... keeping everything to lower case keeps accidents like this > from happening. Well, as long as we have a convention I think we can easily avoid this, and as Monty said, we'll never be creating a session.h and a Session.h per the convention. :) -Eric _______________________________________________ Mailing list: https://launchpad.net/~drizzle-discuss Post to : [email protected] Unsubscribe : https://launchpad.net/~drizzle-discuss More help : https://help.launchpad.net/ListHelp

