On Fri, May 11, 2012 at 3:14 PM, Peter Tröger <[email protected]> wrote: > That's a funny one ... > > It's the perfect time for such comments. We are still waiting for the OGF > officials to start the public comment period for the document. In this > phase, we need the community feedback to show a larger interest in the spec.
I have three more issues: 1) Mac OS and Mac OS X are 2 different platforms. Mac OS is the much older OS that is not supported anymore, and Mac OS X is the one that is based on the Darwin & Unix kernel. May be we should change: DRMAA2_MACOS -> DRMAA2_MACOSX Even Apple sw_vers tool prints Mac OS X as the product name: http://developer.apple.com/library/mac/#documentation/Darwin/Reference/ManPages/man1/sw_vers.1.html 2) We have x86 and the 64-bit version x64, and we also have PPC & PPC64, SPARC & SPARC64. But where is the 64-bit version of ARM (DRMAA2_ARM)? We (the Open Grid Scheduler project) added support for ARM since Open Grid Scheduler/Grid Engine 2011.11, and we think ARM will be used by lots more sites when 64-bit ARM hits the market - note that the 64-bit ARM architecture was announced last year. Also, China developed a series of 64-bit MIPS processors called Loongson, and 64-bit MIPS is manufactured by other companies as well - to keep the architecture selection consistent, shouldn't we also have DRMAA2_MIPS & DRMAA2_MIPS64? 3) DRMAA2_DATA_SEG_SIZE - the data segment does not change when a process runs, as the data segment contains global & static (and common in Fortran) variables. I can't think of anyone who explicitly wanted to limit the size of the data segment. What we do need is a limit for the Heap (sbrk(), malloc(), C++'s new, etc) - this is the memory we care about. IMO, we should change the name to DRMAA2_HEAP_SIZE Rayson ================================= Open Grid Scheduler / Grid Engine http://gridscheduler.sourceforge.net/ Scalable Grid Engine Support Program http://www.scalablelogic.com/ > > I will post the link if it is available. Thanks for your review ! > > Best regards, > Peter. > > >> >> Rayson >> >> ================================= >> Open Grid Scheduler / Grid Engine >> http://gridscheduler.sourceforge.net/ >> >> Scalable Grid Engine Support Program >> http://www.scalablelogic.com/ >> >> >> >> >> On Tue, Apr 17, 2012 at 5:16 AM, Peter Tröger<[email protected]> wrote: >>> >>> Dear all, >>> >>> the DRMAAv2 C binding is now in final draft state. Attached you can find >>> the annotated and the official version of the specification, as well as the >>> raw header file. >>> >>> Please provide your final comments on the mailing list until *April 22nd* >>> (this Sunday). In case, we will set up a conf call for last discussions. >>> Otherwise, the document will enter the OGF document process on next Monday. >>> >>> Thanks and best regards, >>> Peter. >>> >>> >>> >>> -- >>> drmaa-wg mailing list >>> [email protected] >>> https://www.ogf.org/mailman/listinfo/drmaa-wg -- drmaa-wg mailing list [email protected] https://www.ogf.org/mailman/listinfo/drmaa-wg
