Hi Pantelis,

This is the error:
 *This PostgreSQL Database is INCOMPATIBLE with DSpace. The upgrade will
NOT proceed. A supported version (>=1.1) of the 'pgcrypto' extension must
be installed! Please run 'dspace database info' for additional *

To fix it you should install 'pgcrypto'. The pgcrypto module provides
cryptographic functions for PostgreSQL.

You should run the SQL:

CREATE EXTENSION pgcrypto;


Best
Luiz


On Sun, May 22, 2016 at 7:05 PM, Pantelis Karamolegkos <
[email protected]> wrote:

> Here is line 799 of build.xml
>
> <java classname="org.dspace.app.launcher.ScriptLauncher"
> classpathref="class.path" fork="yes" failonerror="yes">
>
> On Mon, May 23, 2016 at 1:35 AM, Luiz dos Santos <[email protected]>
> wrote:
>
>> What do you have on this build.xml in the line 799? Do you see any
>> exception on the ant output?
>>
>> Best
>> Luiz
>>
>> On Sun, May 22, 2016 at 11:59 AM, Pantelis Karamolegkos <
>> [email protected]> wrote:
>>
>>> The above target fails with the following output:
>>>
>>>  [java] 2016-05-22 18:56:33,108 INFO
>>>  org.dspace.services.caching.CachingServiceImpl @ destroy()
>>>      [java] 2016-05-22 18:56:33,109 INFO
>>>  org.springframework.cache.ehcache.EhCacheManagerFactoryBean @ Shutting
>>> down EhCache CacheManager
>>>      [java] 2016-05-22 18:56:33,109 INFO
>>>  org.dspace.services.sessions.SessionRequestServiceImpl @ shutdown
>>>      [java] 2016-05-22 18:56:33,109 WARN
>>>  org.dspace.services.sessions.SessionRequestServiceImpl @ Request
>>> interceptor
>>> (org.dspace.services.events.SystemEventService$EventRequestInterceptor@7d35e191)
>>> failed to execute on end (request-387-1463932592942): null
>>>      [java] 2016-05-22 18:56:33,113 INFO
>>>  org.dspace.servicemanager.spring.SpringServiceManager @ Spring Service
>>> Manager Shutdown...
>>>      [java] 2016-05-22 18:56:33,113 INFO
>>>  org.dspace.servicemanager.DSpaceServiceManager @ Shutdown DSpace core
>>> service manager
>>>      [java] 2016-05-22 18:56:33,113 INFO
>>>  org.dspace.servicemanager.DSpaceKernelImpl @ DSpace kernel shutdown
>>> completed and unregistered MBean:
>>> org.dspace:name=2a65a6db-e965-4813-9766-fce8b7cb4f05,type=DSpaceKernel
>>>
>>> BUILD FAILED
>>> /home/pkaramol/Workspace/dspace_dir/dspace-6.0-rc1-src-release/dspace/target/dspace-installer/build.xml:799:
>>> Java returned: 1
>>>
>>> Working on Ubuntu 16.04, with Postgres 9.5 and Java 1.8.0_91
>>>
>>> --
>>> You received this message because you are subscribed to the Google
>>> Groups "DSpace Technical Support" group.
>>> To unsubscribe from this group and stop receiving emails from it, send
>>> an email to [email protected].
>>> To post to this group, send email to [email protected].
>>> Visit this group at https://groups.google.com/group/dspace-tech.
>>> For more options, visit https://groups.google.com/d/optout.
>>>
>>
>>
>

-- 
You received this message because you are subscribed to the Google Groups 
"DSpace Technical Support" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
To post to this group, send email to [email protected].
Visit this group at https://groups.google.com/group/dspace-tech.
For more options, visit https://groups.google.com/d/optout.

Reply via email to