Hello Stephen,
Ok since it was not solved, you may need to first tail the apache2 logs
live and try uploading, then capture the error logged by Apache; that will
be a starting point.
But also check the permissions on the logs folder in the DSpace backend at
/dspace.
Also in the dspace.cf and local.cf verify whether the file upload limit is
set.

All the best,
Kevon

On Wed, Aug 12, 2026 at 7:30 PM Stephen Michaels <
[email protected]> wrote:

> The major (first) problem wasn't solved by setting the LimitRequestBody to
> unlimited (0) in Apache.
>
> I'm wondering if this could be a directory permissions issue, or if
> something has changed and I'm trying to upload to a non-existent directory.
>
> Steve Michaels, MDiv, MLIS
> Librarian
> Michigan Certified Librarian (Level 1)
> Make an appointment
> <https://scheduler.zoom.us/steve-michaels/30-minute-meeting>
>
> ph  616.372.3656
> 101 East 13th Street, Holland MI 49423-3622
>
>
>
>
> On Wed, Aug 12, 2026 at 11:45 AM Kevon Muhoozi <[email protected]>
> wrote:
>
>> Hello Stephen,
>> Was the first issue solved?
>>
>> Also, DSpace logs depend on your backend configuration.
>> If you used Tomcat 10, then the logs are generated through catalina, but
>> also if it is a systemd setup, you can tail the systemd logs from your file
>> setup.
>>
>> Kind regards,
>> Kevon
>>
>> On Wed, Aug 12, 2026 at 3:09 PM Stephen Michaels <
>> [email protected]> wrote:
>>
>>> The other thing I'm (not) seeing is that the dspace.log file doesn't
>>> exist. The setup seems fine, just no file.
>>>
>>> I do have the dspace-cli.log.
>>>
>>> On Tuesday, August 11, 2026 at 1:33:26 PM UTC-4 Stephen Michaels wrote:
>>>
>>>> We're having issues uploading files to our DSpace 9.3 instance on
>>>> Ubuntu 24.04.4 LTS.
>>>>
>>>> I can upload a file and the browser responds with a 201 response, but
>>>> the interface says "Upload failed". The only error that's being logged
>>>> anywhere is in Tomcat's localhost_access_log file, where I can see a 500
>>>> response on the PATCH request. The other usual suspects are empty of 
>>>> errors.
>>>>
>>>> Where else should I be looking for the problem?
>>>>
>>> --
>>> All messages to this mailing list should adhere to the Code of Conduct:
>>> https://lyrasis.org/code-of-conduct/
>>> ---
>>> You received this message because you are subscribed to the Google
>>> Groups "DSpace Technical Support" group.
>>> To unsubscribe from this group and stop receiving emails from it, send
>>> an email to [email protected].
>>> To view this discussion visit
>>> https://groups.google.com/d/msgid/dspace-tech/6998dc98-febf-425c-81b4-8259b696f3c6n%40googlegroups.com
>>> <https://groups.google.com/d/msgid/dspace-tech/6998dc98-febf-425c-81b4-8259b696f3c6n%40googlegroups.com?utm_medium=email&utm_source=footer>
>>> .
>>>
>>

-- 
All messages to this mailing list should adhere to the Code of Conduct: 
https://lyrasis.org/code-of-conduct/
--- 
You received this message because you are subscribed to the Google Groups 
"DSpace Technical Support" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
To view this discussion visit 
https://groups.google.com/d/msgid/dspace-tech/CA%2BLKazoiOOcn4AL_da%3DU%2BbDF%3Dg5ZimtopEOomwEgp0O4rF%2BpDQ%40mail.gmail.com.

Reply via email to