Thanks, Bernd, for your fast reply.

I got the 2.12 clone. However, the problem with the tutorial persists and when I type "make build_tutorials" in "~/dune/dumux/build-cmake", I get te message that there is no rule for building build_tutorials. (I am using Ubuntu 17.1 in an Oracle Virtual box and DUNE 2.6)

regards, Hermann

Ok, I installed dumux manually in "~/dune/dumux". The test program worked (chapter 2.2 of the handbook), however, the tutorial example (chapter 3.1.5) does not compile. The compiler (g++) does not findĀ  <config.h> and when I comment this line out, it does not find <dumux/porousmediumflow/2p/implicit/model.hh>. So, I guess there must be a PATH problem, but I could not figure out how to solve it. I tried adding "~/dune/dumux" to the PATH, also in the CMakeLists.txt, I have the line "include_directories(~/dune/dumux)". I admit, I am not a specialist in Linux...

I guess (that's what I did), in order to compile the tutorial, I first should go to "~/dune/dumux/tutorial/tutorial_implicit" and type there "make tutorial_implicit".
Can you try a "make build_tutorials" in your top-most CMake build folder, most likely "build-cmake"?

Kind regards

Hermann Zeyen
Departement des Sciences de la Terre
Universite de Paris-Sud, Bat. 504
F-91405 Orsay Cedex, France
Tel: +33-(0)1 69 15 49 09,  Fax: +33-(0)1 69 15 49 05

Dumux mailing list

Reply via email to