Hi anydot,

On Mon, May 28, 2007 at 10:15:09PM +0200, Anydot wrote:
> attached are 3 patches:
> -clean:
>       small cleanup of layout.c for loop in floating() - to have it same
>       styled as loop in tile()

Applied.

> -focusmerge:
>       merges function of focus() and focustopvisible() into one function
>       focus(). It has parameter Client *c and this behaviour:
>               - c == NULL: if selscreen then select topvisible window else
>                 deselect sel (used in leavenotify, while pointer goes to
>                 another screen in multihead setup).
>               - c && isvisible(c): focus that client
>               - else: select topvisible client
>       this makes behaviour of focus(NULL) more intuitive, the function do
>       the best to select the client AND everytime has some client selected
>       - if there is someone visible (and if selscreen, of course :). Also
>       allow some cleanup in layout functions, too;

Applied, though I ask people with a multihead setup to test hg
tip NOW, that I can release 4.2 soon.

> -un_ban:
>       refactor (un)banning of (in)visible clients from layouts functions.
>       Their code is then more readable and it ease creation of another
>       layouts, too

Applied, I agree on that, this removes some clones.

anydot, many thanks for your patches!

Regards,
-- 
 Anselm R. Garbe >< http://www.suckless.org/ >< GPG key: 0D73F361

Reply via email to