On 13/10/16 17:36, shahzeb.siddi...@pfizer.com wrote:
I am getting an error during fpm process for GCC 5.2.0. I have eb set for
packaging by default.

I have given the output of the log where the error occurs.

Which EasyBuild & FPM versions are you using?

The only thing I can get from the error you're seeing is this:

    Process failed: rpmbuild failed (exit code 1)

which is not very useful... Do you have rpmbuild available on your system?

Do you have any useful logs somewhere deeper in the temporary directory used by EasyBuild, i.e. /tmp/eb-lhMLNO in this case?
Maybe in /tmp/eb-lhMLNO/eb-pkgs-GIR_5q ?

I just tried to packaging GCC 5.2.0 myself using FPM 1.3.3 and an existing GCC 5.2.0 installation via "eb GCC-5.2.0.eb --package --skip --force", which worked fine (I was using the current EasyBuild develop version, but that shouldn't matter):

$ ls -l $EASYBUILD_PREFIX/packages
total 483648
-rw-rw-r-- 1 vsc40023 vsc40023 247605409 Oct 13 18:57 GCC-5.2.0-eb_3.0.0.dev0-1.x86_64.rpm



[hpcswadm@amrndhl1155 ~]$ eb --show-full-config
# Current EasyBuild configuration
# (C: command line argument, D: default value, E: environment variable, F:
configuration file)
add-dummy-to-minimal-toolchains (D) = False
aggregate-regtest               (D) = None
allow-modules-tool-mismatch     (D) = False
amend                           (D) = None
avail-cfgfile-constants         (D) = False
avail-easyconfig-constants      (D) = False
avail-easyconfig-licenses       (D) = False
avail-easyconfig-params         (D) = False
avail-easyconfig-templates      (D) = False
avail-module-naming-schemes     (D) = False
avail-modules-tools             (D) = False
avail-repositories              (D) = False
avail-toolchain-opts            (D) = None
buildpath                       (F) = /nfs/grid/software/RHEL7-BUILD/
check-conflicts                 (D) = False
check-github                    (D) = False
cleanup-builddir                (D) = True
cleanup-tmpdir                  (D) = True
color                           (D) = auto
configfiles                     (D) = /hpc/hpcswadm/.config/easybuild/
debug                           (D) = False
debug-lmod                      (D) = False
default-opt-level               (D) = defaultopt
dep-graph                       (D) = None
deprecated                      (D) = None
download-timeout                (D) = None
dry-run                         (D) = False
dry-run-short                   (D) = False
dump-autopep8                   (D) = False
dump-env-script                 (D) = False
dump-test-report                (D) = None
easyblock                       (D) = None
experimental                    (D) = False
extended-dry-run                (D) = False
extended-dry-run-ignore-errors  (D) = True
external-modules-metadata       (D) = None
extra-modules                   (D) = None
filter-deps                     (D) = None
fixed-installdir-naming-scheme  (D) = False
force                           (D) = False
from-pr                         (D) = None
git-working-dirs-path           (D) = None
github-org                      (D) = None
github-user                     (D) = None
group                           (D) = None
group-writable-installdir       (D) = False
hidden                          (D) = False
hide-deps                       (D) = None
hide-toolchains                 (D) = None
ignore-dirs                     (D) = .git, .svn
ignore-osdeps                   (D) = False
ignoreconfigfiles               (D) = None
include-easyblocks              (D) =
include-module-naming-schemes   (D) =
include-toolchains              (D) =
info                            (D) = False
install-github-token            (D) = False
install-latest-eb-release       (D) = False
installpath                     (F) = /nfs/grid/software/RHEL7-apps/
installpath-modules             (D) = None
installpath-software            (D) = None
job                             (D) = False
job-backend                     (D) = PbsPython
job-backend-config              (D) = None
job-cores                       (D) = None
job-max-walltime                (D) = 24
job-output-dir                  (D) = /hpc/hpcswadm
job-polling-interval            (D) = 30.0
job-target-resource             (D) = None
last-log                        (D) = False
list-easyblocks                 (D) = None
list-installed-software         (D) = None
list-software                   (D) = None
list-toolchains                 (D) = False
logfile-format                  (D) = ('easybuild', 'easybuild-%(name)s-%
logtostdout                     (D) = False
minimal-toolchains              (D) = False
module-naming-scheme            (D) = EasyBuildMNS
module-only                     (D) = False
module-syntax                   (D) = Tcl
moduleclasses                   (D) = base, bio, cae, chem, compiler, data,
debugger, devel, geo, ide, lang, lib, math, mpi, numlib, perf, phys, system,
toolchain, tools, vis
modules-footer                  (D) = None
modules-header                  (D) = None
modules-tool                    (D) = EnvironmentModulesC
mpi-cmd-template                (D) = None
mpi-tests                       (D) = True
new-pr                          (D) = False
only-blocks                     (D) = None
optarch                         (D) = None
output-format                   (D) = txt
package                         (F) = True
package-naming-scheme           (D) = EasyBuildPNS
package-release                 (D) = 1
package-tool                    (D) = fpm
package-type                    (D) = rpm
packagepath                     (F) = /nfs/grid/software/RHEL7-BUILD/
parallel                        (D) = None
pr-branch-name                  (D) = None
pr-commit-msg                   (D) = None
pr-descr                        (D) = None
pr-target-account               (D) = hpcugent
pr-target-branch                (D) = develop
pr-target-repo                  (D) = easybuild-easyconfigs
pr-title                        (D) = None
prefix                          (F) = /nfs/grid/software/RHEL7-BUILD/easybuild
pretend                         (D) = False
quiet                           (D) = False
read-only-installdir            (D) = False
rebuild                         (D) = False
recursive-module-unload         (D) = False
regtest                         (D) = False
regtest-output-dir              (D) = None
repository                      (D) = FileRepository
repositorypath                  (F) = /nfs/grid/software/RHEL7-BUILD/
review-pr                       (D) = None
robot                           (D) = None
robot-paths                     (D) = /nfs/grid/software/RHEL7-BUILD/software/
search                          (D) = None
search-filename                 (D) = None
search-short                    (D) = None
sequential                      (D) = False
set-gid-bit                     (D) = False
show-default-configfiles        (D) = False
show-default-moduleclasses      (D) = False
skip                            (D) = False
skip-test-cases                 (D) = False
software                        (D) = None
software-name                   (D) = None
software-version                (D) = None
sourcepath                      (F) = /nfs/grid/software/RHEL7-BUILD/
sticky-bit                      (D) = False
stop                            (D) = None
strict                          (D) = warn
subdir-modules                  (D) = modules
subdir-software                 (D) = software
subdir-user-modules             (D) = None
suffix-modules-path             (D) = all
terse                           (D) = False
test-report-env-filter          (D) = None
testoutput                      (D) = None
tmp-logdir                      (D) = None
tmpdir                          (D) = None
toolchain                       (D) = None
toolchain-name                  (D) = None
toolchain-version               (D) = None
try-amend                       (D) = None
try-software                    (D) = None
try-software-name               (D) = None
try-software-version            (D) = None
try-toolchain                   (D) = None
try-toolchain-name              (D) = None
try-toolchain-version           (D) = None
umask                           (D) = None
unittest-file                   (D) = None
update-modules-tool-cache       (D) = False
update-pr                       (D) = None
upload-test-report              (D) = False
use-ccache                      (D) = False
use-existing-modules            (D) = False
use-f90cache                    (D) = False
zip-logs                        (D) = None

== 2016-10-13 11:24:40,416 easyblock.py:2151 INFO Running method package_step
part of step package
== 2016-10-13 11:24:40,416 easyblock.py:1751 INFO Generating rpm package in /
== 2016-10-13 11:24:40,417 utilities.py:84 INFO Will be creating rpm
package(s) in /tmp/eb-lhMLNO/eb-pkgs-GIR_5q
== 2016-10-13 11:27:25,416 build_log.py:163 ERROR cmd "fpm --workdir /tmp/eb-
lhMLNO/eb-pkgs-GIR_5q --name "GCC-5.2.0" --provides "GCC-5.2.0" -t rpm -s dir
--version eb-2.9.0 --iteration 1 --description "The GNU Compiler Collection
includes front ends for C, C++, Objective-C, Fortran, Java, and Ada,
  as well as libraries for these languages (libstdc++, libgcj,...)." --url
"http://gcc.gnu.org/"; --exclude "nfs/grid/software/RHEL7-apps/software/GCC/
5.2.0/easybuild/*.log" --exclude "nfs/grid/software/RHEL7-apps/software/GCC/
5.2.0/easybuild/*.md"  --depends "M4-1.4.17" /nfs/grid/software/RHEL7-apps/
software/GCC/5.2.0 /nfs/grid/software/RHEL7-apps/modules/all/GCC/5.2.0" exited
with exitcode 1 and output:
{:timestamp=>"2016-10-13T11:24:44.750674-0400", :message=>"Package version
'eb-2.9.0' includes dashes, converting to underscores", :level=>:warn}
{:timestamp=>"2016-10-13T11:27:24.930564-0400", :message=>"Process failed:
rpmbuild failed (exit code 1). Full command was:[\"rpmbuild\", \"-bb\", \"--
define\", \"buildroot /tmp/eb-lhMLNO/eb-pkgs-GIR_5q/package-rpm-build-
e79e52cd019e0a04ae6167285317e4920be2ae178abc20e6818d679ce27b/BUILD\", \"--
define\", \"_topdir /tmp/eb-lhMLNO/eb-pkgs-GIR_5q/package-rpm-build-
e79e52cd019e0a04ae6167285317e4920be2ae178abc20e6818d679ce27b\", \"--define\",
\"_sourcedir /tmp/eb-lhMLNO/eb-pkgs-GIR_5q/package-rpm-build-
e79e52cd019e0a04ae6167285317e4920be2ae178abc20e6818d679ce27b\", \"--define\",
\"_rpmdir /tmp/eb-lhMLNO/eb-pkgs-GIR_5q/package-rpm-build-
e79e52cd019e0a04ae6167285317e4920be2ae178abc20e6818d679ce27b/RPMS\", \"--
define\", \"_tmppath /tmp/eb-lhMLNO/eb-pkgs-GIR_5q\", \"/tmp/eb-lhMLNO/eb-
GCC-5.2.0.spec\"]", :level=>:error}
  (at easybuild/tools/run.py:438 in parse_cmd_output)
== 2016-10-13 11:27:25,416 easyblock.py:2380 WARNING build failed (first 300
chars): cmd "fpm --workdir /tmp/eb-lhMLNO/eb-pkgs-GIR_5q --name "GCC-5.2.0" --
provides "GCC-5.2.0" -t rpm -s dir --version eb-2.9.0 --iteration 1 --
description "The GNU Compiler Collection includes front ends for C, C++,
Objective-C, Fortran, Java, and Ada,
  as well as libraries for these languages (libstdc
== 2016-10-13 11:27:25,417 easyblock.py:269 INFO Closing log for application
name GCC version 5.2.0

Reply via email to