yup of course!~

$ /Users/tess/eclipse/java-oxygen/Eclipse.app/Contents/Eclipse/eclimd      
                                                                  


/Library/Java/JavaVirtualMachines/jdk-9.jdk/Contents/Home/bin/java -version
java version "9"
Java(TM) SE Runtime Environment (build 9+181)
Java HotSpot(TM) 64-Bit Server VM (build 9+181, mixed mode)
JAVA_VERSION=9

/Library/Java/JavaVirtualMachines/jdk-9.jdk/Contents/Home/bin/java -d64 
-Dosgi.requiredJavaVersion=1.8 
-Dosgi.instance.area.default=@user.home/eclipse-workspace -XX:+UseG1GC 
-XX:+UseStringDeduplication --add-modules=ALL-SYSTEM -XstartOnFirstThread 
-Dorg.eclipse.swt.internal.carbon.smallFonts -Xms256m -Xmx1024m 
-Declipse.p2.max.threads=10 -XstartOnFirstThread -jar 
/Users/tess/eclipse/java-oxygen/Eclipse.app/Contents/Eclipse/plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
 
--launcher.suppressErrors -debug -clean -refresh -application 
org.eclim.application
WARNING: Using incubator modules: jdk.incubator.httpclient
Install location:
    file:/Users/tess/eclipse/java-oxygen/Eclipse.app/Contents/Eclipse/
Configuration file:
    
file:/Users/tess/eclipse/java-oxygen/Eclipse.app/Contents/Eclipse/configuration/config.ini
 
loaded
Configuration location:
    
file:/Users/tess/eclipse/java-oxygen/Eclipse.app/Contents/Eclipse/configuration/
Framework located:
    
file:/Users/tess/eclipse/java-oxygen/Eclipse.app/Contents/Eclipse/../../../../../.p2/pool/plugins/org.eclipse.osgi_3.12.50.v20170928-1321.jar
Loading extension: 
reference:file:org.eclipse.osgi.compatibility.state_1.1.0.v20170516-1513.jar
        eclipse.properties not found
Framework classpath:
    
file:/Users/tess/eclipse/java-oxygen/Eclipse.app/Contents/Eclipse/../../../../../.p2/pool/plugins/org.eclipse.osgi_3.12.50.v20170928-1321.jar
    file:/Users/tess/.p2/pool/plugins/
    
file:/Users/tess/eclipse/java-oxygen/Eclipse.app/Contents/Eclipse/../../../../../.p2/pool/plugins/org.eclipse.osgi.compatibility.state_1.1.0.v20170516-1513.jar
Debug options:
    file:/Users/tess/.p2/.options not found
Time to load bundles: 70
org.eclipse.m2e.logback.configuration: The 
org.eclipse.m2e.logback.configuration bundle was activated before the state 
location was initialized.  Will retry after the state location is 
initialized.
Starting application: 3810
org.eclipse.m2e.logback.configuration: Logback config file: 
/Users/tess/eclipse-workspace/.metadata/.plugins/org.eclipse.m2e.logback.configuration/logback.1.8.2.20171007-0217.xml
SLF4J: Class path contains multiple SLF4J bindings.
SLF4J: Found binding in 
[bundleresource://522.fwk537066525:1/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: Found binding in 
[bundleresource://522.fwk537066525:2/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an 
explanation.
SLF4J: Actual binding is of type 
[ch.qos.logback.classic.util.ContextSelectorStaticBinder]
org.eclipse.m2e.logback.configuration: Initializing logback
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by 
org.eclipse.emf.ecore.xmi.impl.XMLHandler 
(file:/Users/tess/.p2/pool/plugins/org.eclipse.emf.ecore.xmi_2.13.0.v20170609-0707.jar)
 
to method 
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser$LocatorProxy.getEncoding()
WARNING: Please consider reporting this to the maintainers of 
org.eclipse.emf.ecore.xmi.impl.XMLHandler
WARNING: Use --illegal-access=warn to enable warnings of further illegal 
reflective access operations
WARNING: All illegal access operations will be denied in a future release
Application Started: 6746
2018-02-13 09:11:55,280 INFO  [org.eclim.eclipse.EclimDaemon] Workspace: 
/Users/tess/eclipse-workspace
2018-02-13 09:11:55,284 INFO  [org.eclim.eclipse.EclimDaemon] Home: 
/Users/tess/.p2/pool/plugins/org.eclim_2.7.2/
2018-02-13 09:11:55,285 INFO  [org.eclim.eclipse.EclimDaemon] Starting 
eclim...
2018-02-13 09:11:55,296 INFO  [org.eclim.eclipse.EclimDaemon] Loading 
plugin org.eclim
2018-02-13 09:11:55,299 INFO  [org.eclim.eclipse.EclimDaemon] Loading 
plugin org.eclim.core
2018-02-13 09:11:55,424 INFO  [org.eclim.plugin.core.CorePlugin] Loading 
eclim plugins...
2018-02-13 09:11:55,430 INFO  [org.eclim.plugin.core.CorePlugin] Loading 
plugin org.eclim.jdt
2018-02-13 09:11:55,433 INFO  [org.eclim.plugin.core.CorePlugin] Loading 
plugin org.eclim.pydev
2018-02-13 09:11:55,434 INFO  [org.eclim.plugin.core.CorePlugin] Plugins 
loaded.
2018-02-13 09:11:55,435 INFO  [org.eclim.eclipse.EclimDaemon] Loaded plugin 
org.eclim.core
2018-02-13 09:11:55,435 INFO  [org.eclim.eclipse.EclimDaemon] Waiting on 
running jobs before starting eclimd...
2018-02-13 09:11:58,441 INFO  [org.eclim.eclipse.EclimDaemon] Jobs finished.
2018-02-13 09:11:58,441 INFO  [org.eclim.eclipse.EclimDaemon] Eclim Server 
Started on: 127.0.0.1:9091




On Tuesday, February 13, 2018 at 9:02:58 AM UTC-8, Eric Van Dewoestine 
wrote:
>
> Can you post the output when starting eclimd in a console? 
>
> On 2018-02-12 17:28:59, 'Tess Winlock' via eclim-user wrote: 
> > Hey there! LONG time eclim user, but finally ran into an issue. So far 
> i've 
> > tracked the problem down to that the jdt nature didn't install when i 
> > upgraded to oxygen & java9. My guess is that this is all related to my 
> > company's recent force-switch over to java 9. 
> > 
> > Using macosx & neovim (tried with vanilla vim, macvim, its clearly in 
> > eclipse and not vim) 
> > 
> > setup was pretty much: 
> > run that silly installer ui from eclipse 
> > 
> > 
> > ./eclim_2.7.2.bin --yes --eclipse=~/eclipse/java-oxygen/Eclipse.app -- 
> > vimfiles=~/.config/nvim/ --plugins=jdt,pydev 
> > 
> > 
> > 
> > 
> > Anywhoo ran this: 
> > :PingEclim 
> > (0s) system: "/Users/tess/.p2/pool/plugins/org.eclim_2.7.2/bin/eclim" -- 
> > nailgun-server localhost --nailgun-port 9091 -editor vim -command ping 
> > eclim   2.7.2 
> > eclipse 4.7.2 
> > 
> > 
> > :ProjectCreate /Users/tess/workspace/eclipse-workspace/fake_java -n java 
> > 
> > (0s) system: "/Users/tess/.p2/pool/plugins/org.eclim_2.7.2/bin/eclim" -- 
> > nailgun-server localhost --nailgun-port 9091 -editor vim -command 
> > project_create -f "/Users/tess/workspace 
> > /eclipse-workspace/fake_java" -n java 
> > java.lang.IllegalArgumentException: Unable to find nature for alias 
> 'java'. 
> >  Supported aliases include: python=org.python.pydev.pythonNature 
> > ^Iat org.eclim.plugin.core.project.ProjectManagement.create( 
> > ProjectManagement.java:161) 
> > ^Iat org.eclim.plugin.core.command.project.ProjectCreateCommand.execute( 
> > ProjectCreateCommand.java:68) 
> > ^Iat org.eclim.command.Main$1.run(Main.java:100) 
> > ^Iat org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:37) 
> > ^Iat 
> org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java 
> > :182) 
> > ^Iat org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4034) 
> > ^Iat org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3701) 
> > ^Iat org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$5.run( 
> > PartRenderingEngine.java:1150) 
> > ^Iat 
> org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java 
> > :336) 
> > ^Iat org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run( 
> > PartRenderingEngine.java:1039) 
> > ^Iat org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI( 
> > E4Workbench.java:153) 
> > ^Iat org.eclipse.ui.internal.Workbench.lambda$3(Workbench.java:680) 
> > ^Iat 
> org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java 
> > :336) 
> > ^Iat 
> org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java: 
> > 594) 
> > ^Iat 
> org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148) 
> > ^Iat org.eclipse.ui.internal.ide.application.IDEApplication.start( 
> > IDEApplication.java:151) 
> > ^Iat org.eclim.eclipse.EclimApplication.start(EclimApplication.java:128) 
> > ^Iat 
> org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle. 
> > java:196) 
> > ^Iat org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher. 
> > runApplication(EclipseAppLauncher.java:134) 
> > ^Iat org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start( 
> > EclipseAppLauncher.java:104) 
> > ^Iat 
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java 
> > :388) 
> > ^Iat 
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java 
> > :243) 
> > ^Iat 
> java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native 
> > Method) 
> > ^Iat java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke( 
> > NativeMethodAccessorImpl.java:62) 
> > ^Iat java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke( 
> > DelegatingMethodAccessorImpl.java:43) 
> > ^Iat java.base/java.lang.reflect.Method.invoke(Method.java:564) 
> > ^Iat org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:653) 
> > ^Iat org.eclipse.equinox.launcher.Main.basicRun(Main.java:590) 
> > ^Iat org.eclipse.equinox.launcher.Main.run(Main.java:1499) 
> > ^Iat org.eclipse.equinox.launcher.Main.main(Main.java:1472) 
> > while executing command (port: 9091): -editor vim -command 
> project_create -f 
> > "/Users/tess/workspace/eclipse-workspace/fake_java" -n java 
> > 
> > 
> > 
> > jdt is certainly installed (see the attached dump of a quick search of 
> the 
> > ~/.p2 directory) 
> > 
> > not really sure what to do here, i can downgrade to jdk8, but that'll 
> get 
> > overwritten by all the scripts my company uses. Much as i love my custom 
> > setup, i'm definitely gonna need java 9 support. 
> > 
> > -- 
> > You received this message because you are subscribed to the Google 
> Groups "eclim-user" group. 
> > To unsubscribe from this group and stop receiving emails from it, send 
> an email to eclim-user+...@googlegroups.com <javascript:>. 
> > To post to this group, send email to eclim...@googlegroups.com 
> <javascript:>. 
> > Visit this group at https://groups.google.com/group/eclim-user. 
> > For more options, visit https://groups.google.com/d/optout. 
>
>
>
> -- 
> eric 
>

-- 
You received this message because you are subscribed to the Google Groups 
"eclim-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to eclim-user+unsubscr...@googlegroups.com.
To post to this group, send email to eclim-user@googlegroups.com.
Visit this group at https://groups.google.com/group/eclim-user.
For more options, visit https://groups.google.com/d/optout.

Reply via email to