The library instance is not BASE type, to follow naming convention this patch 
change Basename into 'Uefi*Lib' and module type into 'UEFI_DRIVER'.

Cc: Jaben Carsey <[email protected]>
Cc: Liming Gao <[email protected]>
Contributed-under: TianoCore Contribution Agreement 1.0
Signed-off-by: Qiu Shumin <[email protected]>
---
 MdePkg/Library/UefiFileHandleLib/UefiFileHandleLib.inf | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/MdePkg/Library/UefiFileHandleLib/UefiFileHandleLib.inf 
b/MdePkg/Library/UefiFileHandleLib/UefiFileHandleLib.inf
index 6c98df0..f813eae 100644
--- a/MdePkg/Library/UefiFileHandleLib/UefiFileHandleLib.inf
+++ b/MdePkg/Library/UefiFileHandleLib/UefiFileHandleLib.inf
@@ -13,9 +13,9 @@
 
 [Defines]
   INF_VERSION                    = 0x00010006
-  BASE_NAME                      = BaseFileHandleLib
+  BASE_NAME                      = UefiFileHandleLib
   FILE_GUID                      = 9495D344-9D8A-41f3-8D17-E2FD238C4E71
-  MODULE_TYPE                    = DXE_DRIVER
+  MODULE_TYPE                    = UEFI_DRIVER
   VERSION_STRING                 = 1.0
   LIBRARY_CLASS                  = FileHandleLib|DXE_DRIVER UEFI_APPLICATION 
UEFI_DRIVER DXE_RUNTIME_DRIVER
 
-- 
1.9.5.msysgit.1

_______________________________________________
edk2-devel mailing list
[email protected]
https://lists.01.org/mailman/listinfo/edk2-devel

Reply via email to