Hi All,

Thank you. I installed nasm-2.12.02 and it workd. We will upgrade to RHEL-7 
soon.

Thanks
Fan Chen

-----Original Message-----
From: Laszlo Ersek [mailto:ler...@redhat.com] 
Sent: Monday, September 19, 2016 7:00 PM
To: Chen, Farrah <farrah.c...@intel.com>; 'edk2-de...@ml01.01.org' 
<edk2-de...@ml01.01.org>
Cc: 'xen-de...@lists.xen.org' <xen-de...@lists.xen.org>
Subject: Re: [edk2] edk2 compile error

On 09/18/16 05:38, Chen, Farrah wrote:
> Hi,
> 
> When I compile xen with the latest commit in RHEL 6.7, it failed when make 
> tools. Errors showed when running edk2 build for OvmfPkgX64.
> Bisected and this error occurred from commit 
> 8c8b6fb02342f7aa78e611a5f0f63dcf8fbf48f2.
> 
> commit 8c8b6fb02342f7aa78e611a5f0f63dcf8fbf48f2
> Author: Wei Liu <wei.l...@citrix.com<mailto:wei.l...@citrix.com>>
> Date:   Tue Sep 6 12:54:47 2016 +0100
> 
>     Config.mk: update OVMF commit
> 
> Signed-off-by: Wei Liu wei.l...@citrix.com<mailto:wei.l...@citrix.com>
> 
> 
> We have updated OVMF to the latest master and cleaned everything before 
> rebuilding.
> 
> 
> 
> Steps:
> 
> make clean
> 
> make xen -j8
> 
> ./configure --enable-ovmf
> 
> make tools -j8
> 
> Then the error occurred.
> 
> 
> 
> 
> 
> I also tried:
> 
> git clone https://github.com/tianocore/edk2.git
> 
> cd edk2
> 
> OvmfPkg/build.sh -a X64 -b DEBUG -n 4
> The same error occurred.
> .........................................................................................................................................................
> 
> log:
> ......
> Running edk2 build for OvmfPkgX64
> ......
> /home/www/builds_xen_unstable/xen-src-8c8b6fb0-20160912/tools/firmware
> /ovmf-dir-remote/Build/OvmfX64/DEBUG_GCC44/X64/UefiCpuPkg/Library/CpuE
> xceptionHandlerLib/DxeCpuExceptionHandlerLib/OUTPUT/X64/ExceptionHandl
> erAsm.iii:173: error: invalid combination of opcode and operands
> /home/www/builds_xen_unstable/xen-src-8c8b6fb0-20160912/tools/firmware
> /ovmf-dir-remote/Build/OvmfX64/DEBUG_GCC44/X64/UefiCpuPkg/Library/CpuE
> xceptionHandlerLib/DxeCpuExceptionHandlerLib/OUTPUT/X64/ExceptionHandl
> erAsm.iii:175: error: invalid combination of opcode and operands
> /home/www/builds_xen_unstable/xen-src-8c8b6fb0-20160912/tools/firmware
> /ovmf-dir-remote/Build/OvmfX64/DEBUG_GCC44/X64/UefiCpuPkg/Library/CpuE
> xceptionHandlerLib/DxeCpuExceptionHandlerLib/OUTPUT/X64/ExceptionHandl
> erAsm.iii:177: error: invalid combination of opcode and operands
> /home/www/builds_xen_unstable/xen-src-8c8b6fb0-20160912/tools/firmware
> /ovmf-dir-remote/Build/OvmfX64/DEBUG_GCC44/X64/UefiCpuPkg/Library/CpuE
> xceptionHandlerLib/DxeCpuExceptionHandlerLib/OUTPUT/X64/ExceptionHandl
> erAsm.iii:179: error: invalid combination of opcode and operands
> /home/www/builds_xen_unstable/xen-src-8c8b6fb0-20160912/tools/firmware
> /ovmf-dir-remote/Build/OvmfX64/DEBUG_GCC44/X64/UefiCpuPkg/Library/CpuE
> xceptionHandlerLib/DxeCpuExceptionHandlerLib/OUTPUT/X64/ExceptionHandl
> erAsm.iii:313: error: invalid combination of opcode and operands
> /home/www/builds_xen_unstable/xen-src-8c8b6fb0-20160912/tools/firmware
> /ovmf-dir-remote/Build/OvmfX64/DEBUG_GCC44/X64/UefiCpuPkg/Library/CpuE
> xceptionHandlerLib/DxeCpuExceptionHandlerLib/OUTPUT/X64/ExceptionHandl
> erAsm.iii:315: error: invalid combination of opcode and operands
> make[7]: Leaving directory 
> `/home/www/builds_xen_unstable/xen-src-8c8b6fb0-20160912/tools/firmware/ovmf-dir-remote/Build/OvmfX64/DEBUG_GCC44/X64/UefiCpuPkg/Library/CpuExceptionHandlerLib/DxeCpuExceptionHandlerLib'
> make[7]: *** 
> [/home/www/builds_xen_unstable/xen-src-8c8b6fb0-20160912/tools/firmwar
> e/ovmf-dir-remote/Build/OvmfX64/DEBUG_GCC44/X64/UefiCpuPkg/Library/Cpu
> ExceptionHandlerLib/DxeCpuExceptionHandlerLib/OUTPUT/X64/ExceptionHand
> lerAsm.obj] Error 1
> 
> 
> build.py...
> : error 7000: Failed to execute command
>                 make tbuild 
> [/home/www/builds_xen_unstable/xen-src-8c8b6fb0-20160912/tools/firmwar
> e/ovmf-dir-remote/Build/OvmfX64/DEBUG_GCC44/X64/UefiCpuPkg/Library/Cpu
> ExceptionHandlerLib/DxeCpuExceptionHandlerLib]
> 
> 
> build.py...
> : error F002: Failed to build module
>                 
> /home/www/builds_xen_unstable/xen-src-8c8b6fb0-20160912/tools/firmware
> /ovmf-dir-remote/UefiCpuPkg/Library/CpuExceptionHandlerLib/DxeCpuExcep
> tionHandlerLib.inf [X64, GCC44, DEBUG]
> 
> - Failed -

RHEL-6 does not have a nasm version that is recent enough to build edk2.
RHEL-6 ships nasm-2.07-*, but edk2 requires nasm-2.10 or later with the GCC 
toolchain family.

Please see this mailing list thread:
https://www.mail-archive.com/edk2-devel@lists.01.org/msg14420.html

And the resultant docs commit:
https://github.com/tianocore/edk2/commit/9c4dbdff1d56

... Before anyone suggests otherwise, this was not a gratuitous version 
requirement bump. The edk2 assembly code had already been there, the nasm 
version bump only documented the status, after the fact.

For RHEL-6 specifically, I suggest to grab a recent enough nasm SRPM from 
Fedora Koji, and rebuild / install that locally. Better yet, I recommend 
upgrading to RHEL-7, whose nasm is good enough.

Thanks
Laszlo

_______________________________________________
edk2-devel mailing list
edk2-devel@lists.01.org
https://lists.01.org/mailman/listinfo/edk2-devel

Reply via email to