On 23 February 2018 at 03:17, Guo Heyi <heyi....@linaro.org> wrote:
> Hi Jeremy,
>
> This TF binaries have not been patched the latest SMCCC workaround; it is 
> based
> on v1.4 release and was only
> patched with "disable/enable MMU in PSCI SMC call", as the commit in upstream 
> TF
> code:
> f62ad322695d16178db464dc062fe0af592c6780
>
> When we generated these binaries, SMCCC patches had not come out so they are 
> not
> contained in these binaries.
>
> Do you recommend using the latest smccc patches?
>

Yes.

The Spectre v2 mitigations that landed in v4.16 and were backported to
v4.15 and v4.14 LTS do not use the PSCI_VERSION call anymore to
perform branch predictor invalidation. Instead, it checks for
SMCCCv1.1, and uses the ARCH_WORKAROUND_1 SMC call if supported. If
not, no BP maintenance is performed.
_______________________________________________
edk2-devel mailing list
edk2-devel@lists.01.org
https://lists.01.org/mailman/listinfo/edk2-devel

Reply via email to