Hi Braden!
Sorry ,this is my thread:
https://groups.google.com/forum/#!topic/edx-code/HOOqg-SiILs
I am using fullstack (Eucalyptus 1).
Thank you Braden !

Vào 05:22:00 UTC+7 Thứ Hai, ngày 19 tháng 9 năm 2016, Braden MacDonald đã 
viết:
>
> Hi Truong,
>
> Could you please start a new thread for questions that are not related to 
> third party authentication?
>
> I'm not sure what the issue is, but when you post a new thread, it would 
> help if you specify what kind of installation you're using. (Devstack, 
> fullstack, AWS "sandbox" playbook, ...). It seems that whatever ansible 
> playbooks were run did not install ecommerce.
>
> --
> Braden
> @OpenCraft <http://opencraft.com/>
>
> On Sun, Sep 18, 2016 at 8:47 AM, truong nguyen <41204219...@gmail.com 
> <javascript:>> wrote:
>
>> Hi Braden!
>> Recently I try to set up E-Commerce service,I follow instruction below:
>>
>> https://openedx.atlassian.net/wiki/display/OpenOPS/How+to+Install+and+Start+the+E-Commerce+Service+in+Native+Installations
>> But when I do these step,it error: 
>>                                                
>> sudo su ecommerce -s /bin/bash  #Error is: Unknow id: ecommerce;
>> You can help me please !
>> Thank you very much Braden.
>> Vào 06:54:53 UTC+7 Thứ Bảy, ngày 17 tháng 9 năm 2016, Braden MacDonald đã 
>> viết:
>>>
>>> Open edX does not support LDAP, no. It only supports OAuth2, OAuth1, 
>>> SAML, and LTI for third party authentication.
>>>
>>> In case you didn't find it already, once you enable the third party auth 
>>> feature, you can configure OAuth2 providers in the django admin 
>>> at /admin/third_party_auth/oauth2providerconfig/
>>>
>>> --
>>> Braden
>>> @OpenCraft <http://opencraft.com/>
>>>
>>> On Thu, Sep 15, 2016 at 7:26 PM, truong nguyen <41204219...@gmail.com> 
>>> wrote:
>>>
>>>> Thank you very much for your reply !
>>>> My platform is Eucalyptus 1
>>>> I try to use OAuth2 providers and your reply hepl me very much in my 
>>>> school project,Thank you again !
>>>> I don't know if my platform supports authentication by LDAP and it 
>>>> has,how I set up ?
>>>>
>>>>
>>>> Vào 01:45:32 UTC+7 Thứ Sáu, ngày 16 tháng 9 năm 2016, Braden MacDonald 
>>>> đã viết:
>>>>>
>>>>> Hi,
>>>>>
>>>>> The procedure for setting up third party authentication in Dogwood and 
>>>>> Eucalyptus has changed.
>>>>>
>>>>> The official documentation is at 
>>>>> http://edx.readthedocs.io/projects/edx-installing-configuring-and-running/en/latest/configuration/tpa/index.html
>>>>>  
>>>>> although the instructions for setting up OAuth2 providers and LTI 
>>>>> authentication has not yet been fully added there.
>>>>>
>>>>> Which third party authentication provider are you trying to set up?
>>>>>
>>>>> --
>>>>> Braden
>>>>> @OpenCraft <http://opencraft.com/>
>>>>>
>>>>> On Wed, Sep 14, 2016 at 11:09 PM, truong nguyen <41204219...@gmail.com
>>>>> > wrote:
>>>>>
>>>>>> Hi friend!
>>>>>> I am use it with fullstack
>>>>>>
>>>>>> Vào 11:36:00 UTC+7 Thứ Năm, ngày 15 tháng 9 năm 2016, Дмитрий Утробин 
>>>>>> đã viết:
>>>>>>
>>>>>>> Hello! Do you use it with devstack?
>>>>>>>
>>>>>>> четверг, 15 сентября 2016 г., 9:28:14 UTC+7 пользователь truong 
>>>>>>> nguyen написал:
>>>>>>>>
>>>>>>>> I try to follow tutorial below:
>>>>>>>>
>>>>>>>> http://johnmcox.blogspot.com/2014/05/getting-started-with-edx-third-party.html
>>>>>>>>  in order to use Third-Party Authentication but after I reconfigure 
>>>>>>>> the database :ERROR
>>>>>>>> ---> pavelib.servers.update_db
>>>>>>>> ---> pavelib.prereqs.install_prereqs
>>>>>>>> NO_PREREQ_INSTALL is set, not installing prereqs
>>>>>>>> NO_EDXAPP_SUDO=1 EDX_PLATFORM_SETTINGS_OVERRIDE=aws 
>>>>>>>> /edx/bin/edxapp-migrate-lms --traceback --pythonpath=.
>>>>>>>> Traceback (most recent call last):
>>>>>>>>   File "manage.py", line 111, in <module>
>>>>>>>>     startup = importlib.import_module(edx_args.startup)
>>>>>>>>   File "/usr/lib/python2.7/importlib/__init__.py", line 37, in 
>>>>>>>> import_module
>>>>>>>>     __import__(name)
>>>>>>>>   File "/edx/app/edxapp/edx-platform/lms/startup.py", line 10, in 
>>>>>>>> <module>
>>>>>>>>     settings.INSTALLED_APPS  # pylint: disable=pointless-statement
>>>>>>>>   File 
>>>>>>>> "/edx/app/edxapp/venvs/edxapp/local/lib/python2.7/site-packages/django/conf/__init__.py",
>>>>>>>>  
>>>>>>>> line 48, in __getattr__
>>>>>>>>     self._setup(name)
>>>>>>>>   File 
>>>>>>>> "/edx/app/edxapp/venvs/edxapp/local/lib/python2.7/site-packages/django/conf/__init__.py",
>>>>>>>>  
>>>>>>>> line 44, in _setup
>>>>>>>>     self._wrapped = Settings(settings_module)
>>>>>>>>   File 
>>>>>>>> "/edx/app/edxapp/venvs/edxapp/local/lib/python2.7/site-packages/django/conf/__init__.py",
>>>>>>>>  
>>>>>>>> line 92, in __init__
>>>>>>>>     mod = importlib.import_module(self.SETTINGS_MODULE)
>>>>>>>>   File "/usr/lib/python2.7/importlib/__init__.py", line 37, in 
>>>>>>>> import_module
>>>>>>>>     __import__(name)
>>>>>>>>   File "/edx/app/edxapp/edx-platform/lms/envs/aws.py", line 439, in 
>>>>>>>> <module>
>>>>>>>>     AUTH_TOKENS = json.load(auth_file)
>>>>>>>>   File "/usr/lib/python2.7/json/__init__.py", line 290, in load
>>>>>>>>     **kw)
>>>>>>>>   File "/usr/lib/python2.7/json/__init__.py", line 338, in loads
>>>>>>>>     return _default_decoder.decode(s)
>>>>>>>>   File "/usr/lib/python2.7/json/decoder.py", line 369, in decode
>>>>>>>>     raise ValueError(errmsg("Extra data", s, end, len(s)))
>>>>>>>> ValueError: Extra data: line 205 column 1 - line 215 column 1 (char 
>>>>>>>> 7059 - 7451)
>>>>>>>> Traceback (most recent call last):
>>>>>>>>   File "manage.py", line 111, in <module>
>>>>>>>>     startup = importlib.import_module(edx_args.startup)
>>>>>>>>   File "/usr/lib/python2.7/importlib/__init__.py", line 37, in 
>>>>>>>> import_module
>>>>>>>>     __import__(name)
>>>>>>>>   File "/edx/app/edxapp/edx-platform/lms/startup.py", line 10, in 
>>>>>>>> <module>
>>>>>>>>     settings.INSTALLED_APPS  # pylint: disable=pointless-statement
>>>>>>>>   File 
>>>>>>>> "/edx/app/edxapp/venvs/edxapp/local/lib/python2.7/site-packages/django/conf/__init__.py",
>>>>>>>>  
>>>>>>>> line 48, in __getattr__
>>>>>>>>     self._setup(name)
>>>>>>>>   File 
>>>>>>>> "/edx/app/edxapp/venvs/edxapp/local/lib/python2.7/site-packages/django/conf/__init__.py",
>>>>>>>>  
>>>>>>>> line 44, in _setup
>>>>>>>>     self._wrapped = Settings(settings_module)
>>>>>>>>   File 
>>>>>>>> "/edx/app/edxapp/venvs/edxapp/local/lib/python2.7/site-packages/django/conf/__init__.py",
>>>>>>>>  
>>>>>>>> line 92, in __init__
>>>>>>>>     mod = importlib.import_module(self.SETTINGS_MODULE)
>>>>>>>>   File "/usr/lib/python2.7/importlib/__init__.py", line 37, in 
>>>>>>>> import_module
>>>>>>>>     __import__(name)
>>>>>>>>   File "/edx/app/edxapp/edx-platform/lms/envs/aws.py", line 439, in 
>>>>>>>> <module>
>>>>>>>>     AUTH_TOKENS = json.load(auth_file)
>>>>>>>>   File "/usr/lib/python2.7/json/__init__.py", line 290, in load
>>>>>>>>     **kw)
>>>>>>>>   File "/usr/lib/python2.7/json/__init__.py", line 338, in loads
>>>>>>>>     return _default_decoder.decode(s)
>>>>>>>>   File "/usr/lib/python2.7/json/decoder.py", line 369, in decode
>>>>>>>>     raise ValueError(errmsg("Extra data", s, end, len(s)))
>>>>>>>> ValueError: Extra data: line 205 column 1 - line 215 column 1 (char 
>>>>>>>> 7059 - 7451)
>>>>>>>>
>>>>>>>>
>>>>>>>> Captured Task Output:
>>>>>>>> ---------------------
>>>>>>>>
>>>>>>>> ---> pavelib.servers.update_db
>>>>>>>> ---> pavelib.prereqs.install_prereqs
>>>>>>>> NO_EDXAPP_SUDO=1 EDX_PLATFORM_SETTINGS_OVERRIDE=aws 
>>>>>>>> /edx/bin/edxapp-migrate-lms --traceback --pythonpath=.
>>>>>>>>
>>>>>>>> Build failed running pavelib.servers.update_db: Subprocess return 
>>>>>>>> code: 1
>>>>>>>> *Please help me*
>>>>>>>>
>>>>>>> -- 
>>>>>> You received this message because you are subscribed to the Google 
>>>>>> Groups "General Open edX discussion" group.
>>>>>> To view this discussion on the web visit 
>>>>>> https://groups.google.com/d/msgid/edx-code/fc55185d-2d72-40e0-9341-717562be34ad%40googlegroups.com
>>>>>>  
>>>>>> <https://groups.google.com/d/msgid/edx-code/fc55185d-2d72-40e0-9341-717562be34ad%40googlegroups.com?utm_medium=email&utm_source=footer>
>>>>>> .
>>>>>>
>>>>>
>>>>> -- 
>>>> You received this message because you are subscribed to the Google 
>>>> Groups "General Open edX discussion" group.
>>>> To view this discussion on the web visit 
>>>> https://groups.google.com/d/msgid/edx-code/16a3280b-e246-4be8-85e5-786d3ac2f2e8%40googlegroups.com
>>>>  
>>>> <https://groups.google.com/d/msgid/edx-code/16a3280b-e246-4be8-85e5-786d3ac2f2e8%40googlegroups.com?utm_medium=email&utm_source=footer>
>>>> .
>>>>
>>>
>>> -- 
>> You received this message because you are subscribed to the Google Groups 
>> "General Open edX discussion" group.
>> To view this discussion on the web visit 
>> https://groups.google.com/d/msgid/edx-code/4c06487c-8927-43cd-b578-a54976f41c9f%40googlegroups.com
>>  
>> <https://groups.google.com/d/msgid/edx-code/4c06487c-8927-43cd-b578-a54976f41c9f%40googlegroups.com?utm_medium=email&utm_source=footer>
>> .
>>
>
>

-- 
You received this message because you are subscribed to the Google Groups 
"General Open edX discussion" group.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/edx-code/e9839f99-70c4-4978-85e8-9eaa83fb2666%40googlegroups.com.

Reply via email to