Hi,

I am using langdetect plugin to dynamically assign the analyzer at index 
time.

PUT test
POST test/article/_mapping 
{
  "article" : {
    "_analyzer" : {
        "path" : "description.lang"
    },
    "properties" : {
       "description" : { "type" : "langdetect" }
    }
  }
}


Langdetect plugin detects the language as 'en', 'fr', 'de', and so on. so 
the analyzers should be defined as 'en', etc. This make them less 
descriptive and the context of analyzer is lost. Is it possible to derive a 
more descriptive name, such that _analyzer is resolve to 'en_icu_analyzer', 
instead of just 'en'?

Something like... (this does not work), this is just what i want to 
achieve. 

article" : {
    "_analyzer" : {
        "path" : "description.lang" + "_icu_analyzer"
    }


Another question - is it possible to define analyzer dynamically at field 
level rather than at the index level?

Thanks,
Nitin

-- 
You received this message because you are subscribed to the Google Groups 
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
To view this discussion on the web visit 
https://groups.google.com/d/msgid/elasticsearch/fc1b9d30-0200-411c-8bba-8939c7f87fe3%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to