Thanks, Don. That fixed it. I remember the KIO2 manual (I think) saying to 
check that after making the Control Board mod, but the mod had been done 10 
years ago (by you. hi), and I guess I decided to follow my nose down a wrong 
turn instead of asking for directions.

This K2 is used mostly for digital modes and the other for CW only. I bought it 
on ebay about 10 years ago and it was such a mess I sent it to you to get it 
working and install all the mods. It's been a flawless performer since then. I 
sent your letter describing what you had to do to it to the ebay seller and he 
sent me a $100 check to compensate me!

Thanks again. I'm relieved that it was something simple. Even more relieved to 
have unprecedented support such as yours.

Eric KE6US

On 9/16/2016 3:22 PM, Don Wilhelm wrote:

Yes, you can swap the Control Boards between the 2 K2s for that test.
Just don't get them mixed up and do not change any of the menu or calibration 
settings in the process.
The EEPROM values are for the K2 that it was aligned with!

It may be easier than that - Has this K2 lost its sidetone too?  If so, that is 
the problem (unless your firmware is 2.04r).  Go to the STL menu and tap 
DISPLAY until you hear sidetone - the sidetone source must be U8-4.


On 9/16/2016 5:46 PM, Eric J wrote:
K2 s/n 567 has gone deaf to I/O access. It's current for mods. Everything else 
in the radio seems to work fine. VFOs tune, all switch functions appear to 
work, Port is ON, etc. If I connect it to the EC2-mounted KPA100, operating the 
power output knob causes the Low/High Power LEDs to indicate properly. I'm 
guessing that just means the AUX Bus is working, but my problem is probably 
with RXD.

The KIO2 is OK. I swapped it out with the one in my other K2 s/n 6911 and both 
work fine in that rig.

Both K2's are connected to a PC via separate USB converter cables. The 
converters both work and the special USB-K2 cables work with either K2. They 
have been in almost daily use for several months, and worked fine.

I put a scope on Pin 3 of the KIO2 connector and issued a Get command to read a 
VFO, then traced the resulting characters all the way to MCU pin 26. A Set 
command also could be traced from pin 26 back. Lots more characters were 
generated for Set than for Get, so that all looks OK.

I'm stuck as I don't know anything at all about what's happening from the MCU, 
or how to test it, but it looks like it's getting what it needs from the PC. Is 
it the MCU (v. 2.04) itself that is at fault?

I'm nervous about swapping the control board from s/n 6911 even though the 
older K2 board is current on mods. If it's safe to do, I'll try it.

Any help appreciated. This is the first failure of either K2 so no complaints 
from me.

Eric KE6US

Elecraft mailing list

This list hosted by:
Please help support this email list:
Message delivered to<>


Elecraft mailing list

This list hosted by:
Please help support this email list:
Message delivered to

Reply via email to