Hi List,

I recently switched my system (Slackware 12.1) over to utf-8,[1] and
essentially the only problem I'm running into is viewing html mail with
mutt. In order to deal with html mail, I used to have the following line in
my .mailcap:

text/html; links -dump -codepage iso-8859-15 -html-numbered-links 1 -force-html 
%s; copiousoutput

and set the appropriate options in .muttrc. Since links doesn't (appear to)
understand utf-8 (I changed the -codepage option to no effect), I was
hoping to be able to use elinks to convert html mail to text. Unfortunately
it doesn't work properly. I get quite a bit of German email, containing
characters like ä, ö, ü and ß (Umlaut-a, o and u, and sharp s). When elinks
dumps an html mail, these are all displayed as question marks in a diamond:
� (unicode 0xFFFD).

In non-html mail, those characters are displayed fine, which suggests to me
that neither mutt nor Xfce's Terminal which I use to runn mutt have a
problem. I must add that I normally run mutt in a screen session, but the
same problem occurs when I run it without screen, directly in Terminal.

The .mailcap entry I use for elinks is this:

text/html; elinks -dump 1 -dump-charset utf-8 -force-html %s; copiousoutput

I've also tried without the -dump-charset option, but got the same effect.

Does anyone have an idea as to what I might be doing wrong, or how I can
figure out what's going wrong?



[1]  That is, I changed the system-wide locale setting in
/etc/profile.d/lang.[c]sh. LANG is set to en_US.UTF-8.

Joost Kremers, PhD
University of Frankfurt
Institute for Cognitive Linguistics
Grüneburgplatz 1
60629 Frankfurt am Main, Germany
elinks-users mailing list

Reply via email to