In Elm 0.18, primes are being removed as valid characters in a 
variable/function name. The reason being, which I whole heartedly agree 
with, that removing primes will incentivize people to write proper names, 
and also because the difference between model and model' isn't always easy 
to spot.

In the same spirit, I propose that we change the name of foldl to foldLeft, 
and the name of foldr to foldRight. The difference between foldl and foldr 
isn't to spot at a cursory glance. foldLeft is also more self-describing 
than foldl, it also matches what I say when I read foldl aloud while 
explaining code to others.

FYI: Scala has also called their functions foldLeft and foldRight.

I think this proposal would benefit both seasoned and new Elm developers.

-- 
You received this message because you are subscribed to the Google Groups "Elm 
Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to elm-discuss+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to