This sounds fine to me. It's certainly a lot better than:

type Msg
  = SwitchCowToExpandedReadOnly
  | SwitchCowToCollapsedReadOnly
  | SwitchCowToReadWrite
  | SwitchChickenToCollapsedReadOnly
  | ...

I think it largely hinges on your ability to separate orthogonal behavior 
as separate types. If Animal and EditMode make sense as types, and you can 
write useful functions that only take one, then that's what you should do. 
If animals and edit modes and actions have interwoven dependencies, things 
are of course trickier.

-- 
You received this message because you are subscribed to the Google Groups "Elm 
Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to elm-discuss+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to