Eric Schulte <schulte.eric <at>> writes:

> Hi d.tchin,

Hi Eric

> This problem is caused because (as you point out) the calc-command-flags
> variable is not defined.  In my Emacs version calc-command-flags is
> provided by (require 'calc) which is part of Babel's calc support, this
> variable must be part of another package in your distribution.

Strange as I can load calc package in emacs. Indeed when I try to 
get information on this variable with C-h v, there is nothing.
I have a look on calc.el and I have the following lines (1428):

(defvar calc-aborted-prefix nil)
(defvar calc-start-time nil)
(defvar calc-command-flags)
(defvar calc-final-point-line)
(defvar calc-final-point-column)

Indeed, when I tried to use C-h v on the two first variable, it match.
But not for the following. The main difference is that the first two 
variable have the nil value and not the following.

> As a work around you should find which calc package provides the
> calc-command-flags variable and manually require that package, which
> should resolve this problem.  More generally it may be useful to upgrade
> from Emacs 22 if that is an option.

I put a (require 'calc) in my .emacs. It is still not working.
I decide to put the following instruction in my .emacs :

(require 'calc) 
(defvar calc-command-flags nil)

Then it works ! 
It seems that there is problem of initialization of this variable.
Shouldn't this variable be initialized by default in calc ?

Thank you for your help.


> Best -- Eric

Emacs-orgmode mailing list
Please use `Reply All' to send replies to the list.

Reply via email to