Hello all,

I believe this is my first post on this list, and I'm very new to org-babel, so 
forgive me if I am posting nonsense.  However, I'm really enthused about the 
possibilities org-babel presents.  Unfortunately, I can't seem to get graphics 
to insert themselves properly on export.  I've included an example that 
reproduces my problem below.  For what it's worth, I am using Windows 7 with a 
freshly downloaded issue of Vincent Goulet's package.  Session info:

Emacs version: GNU Emacs 23.4.1 (i386-mingw-nt6.1.7601) of 2012-02-04 on MARVIN
Org mode version 7.8.03
ESS version 5.14
R version 2.14.1

Many thanks for any thoughts or requests for more info.

Matt

org example
----------------------------

#+TITLE: An attempt to make org-mode work with R

In this example, I want to fit a regression and plot it.  I'm
following the examples at the [[http://orgmode.org/worg/org-
contrib/babel/languages/ob-doc-R.html][org manual]] and Erik Iverson's 
[[https://github.com/erikriverson/org-mode-R-tutorial][tutorial]].

* A stand-alone code block

First, create some data, perform a regression, and plot it.  This
works great.
#+begin_src R :results graphics :file regress.png :exports both

  x <- runif(n = 100, min = 0, max = 20)
  y <- 5*x^2 + 0.3*x + 3 + rnorm(100, sd = 200)

  f <- lm(y ~ x)

  plot(x, y, bty = 'n')
  abline(f, lty = 'dashed')

#+end_src
Success.

* In code blocks using ":session"
Now do the same thing, but across an unnamed session

#+begin_src R :session :exports code :results silent

  x <- runif(n = 100, min = 0, max = 20)
  y <- 5*x^2 + 0.3*x + 3 + rnorm(100, sd = 200)

#+end_src

Now, I would like to display the results of the regression as R output.

#+begin_src R :session :results output :exports both
  f <- lm(y ~ x)
  summary(f)
#+end_src
Again, success!  This is really going to come in handy.

#+begin_src R :session :results graphics :file regress_session.png :exports both

 plot(x, y, bty = 'n')
 abline(f, lty = 'dashed')

#+end_src
This code block doesn't work. No error, but no file is created.
Also, if I press C-c C-c in the code block, in the org file I get

#+begin_example
#+results:
[[file:regress_session.png]]
#+end_example

But no file is actually created.  What could be going wrong?



Reply via email to