On Fri, Jan 5, 2018 at 4:04 AM, Carsten Haitzler <ras...@rasterman.com> wrote:
> raster pushed a commit to branch master.
>
> http://git.enlightenment.org/core/efl.git/commit/?id=76b837002eaea56b5ecb174bffe284012084dc74
>
> commit 76b837002eaea56b5ecb174bffe284012084dc74
> Author: Carsten Haitzler (Rasterman) <ras...@rasterman.com>
> Date:   Fri Jan 5 15:01:02 2018 +0900
>
>     efl loop - provide efl namespace versions of begin/end locks on mainloop
>
>     add efl_main_loop_steal() and efl_main_loop_release() for new efl
>     namespace versiosn of ecore_thread_main_loop_begin() and
>     ecore_thread_main_loop_end().

> +EAPI int
> +efl_main_loop_steal(void)
> +{
> +   return ecore_thread_main_loop_begin();
> +}
> +
> +EAPI int
> +efl_main_loop_release(void)
> +{
> +   return ecore_thread_main_loop_end();
> +}

since we're targeting multi loop and all, this construct in the new
API should be multi-loop as well, that is we should have:

efl_loop_steal(loop);
efl_loop_release(loop);

btw, these names are confusing... I like the old ecore version better,
something like:


efl_loop_thread_usage_begin(loop);
efl_loop_thread_usage_end(loop);

or my preference:

efl_loop_thread_pause(loop);
efl_loop_thread_resume(loop);


anyway, if by final EO api release we still offer efl_main_loop
helpers (I think we shouldn't!), then you can offer your helpers on
top of that.



-- 
Gustavo Sverzut Barbieri
--------------------------------------
Mobile: +55 (16) 99354-9890

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
enlightenment-devel mailing list
enlightenment-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-devel

Reply via email to